Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 215019 - Source Windows opens in wrong pane
Source Windows opens in wrong pane
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
7.2
PC Windows 7
: P3 with 1 vote (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
72ca-not-a-stopper
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-30 12:28 UTC by xgathos
Modified: 2014-09-22 18:06 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Multiton.php via click in "Projects" - opens in wrong panel (151.34 KB, image/jpeg)
2012-06-30 12:34 UTC, xgathos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xgathos 2012-06-30 12:28:36 UTC
[ BUILD # : 201206291011 ]
[ JDK VERSION : 1.7.5 ]

When you open a file from search or projects panel, sometimes the file does not
open in the source panel as expected but in the the source or projects panel...
this is a really annoying usability problem.
Comment 1 xgathos 2012-06-30 12:34:13 UTC
Created attachment 121612 [details]
Multiton.php via click in "Projects" - opens in wrong panel
Comment 2 dejlek 2012-07-02 08:06:46 UTC
I can confirm this bug.
It is not related only to PHP projects, but also Java ones as well.
It is simple to reproduce - make a Java project, work little bit with it, and try to open Java files from the file list, project list, or some other way (search dockable is a good option as well). At some point, the source file will be opened *inside* a dockable where the control is, instead of typically wider space for the source code...
The bug exists in RC1 too.
Comment 3 Tomas Danek 2012-07-09 15:12:49 UTC
Do I understand correctly that this happens randomly?
Can you please be more specific about steps to reproduce  - some sequence of steps that leads to this behavior if repeated n-times?
Thanks in advance.
Comment 4 Stanislav Aubrecht 2012-07-16 12:35:05 UTC
This is not a bug, from the screen shot I can see that you've dragged and dropped a lot of windows around. The result is that you've turned all docking spots in the main window into 'document' areas so all your windows (Projects, Files, Output) are treated as document windows.
Just click menu Window - Reset Windows to fix this.
Comment 5 stevenmz 2014-01-30 16:46:46 UTC
(In reply to Stanislav Aubrecht from comment #4)
> This is not a bug, from the screen shot I can see that you've dragged and
> dropped a lot of windows around. The result is that you've turned all
> docking spots in the main window into 'document' areas so all your windows
> (Projects, Files, Output) are treated as document windows.
> Just click menu Window - Reset Windows to fix this.

Stanislav,

Maybe it is not a "bug" but it is still annoying and should be "fixed" by changing the behavior to not treat all areas as document areas. Doing Window - Reset Windows is a workaround to get the IDE to have expected behavior (open source files in the main area), it is definitly not a fix. Everytime a user has to run that menu command, they have to go about putting the panes back where they prefer them. This behavior is not intuitive and it is frustrating. How many times will a user "reset windows" before they get frustrated and switch to another IDE that behaves as they expect it to?

Experienced on Netbeans 7.4 (OS X)
Comment 6 Stanislav Aubrecht 2014-02-04 09:37:58 UTC
(In reply to stevenmz from comment #5)
> (In reply to Stanislav Aubrecht from comment #4)
> > This is not a bug, from the screen shot I can see that you've dragged and
> > dropped a lot of windows around. The result is that you've turned all
> > docking spots in the main window into 'document' areas so all your windows
> > (Projects, Files, Output) are treated as document windows.
> > Just click menu Window - Reset Windows to fix this.
> 
> Stanislav,
> 
> Maybe it is not a "bug" but it is still annoying and should be "fixed" by
> changing the behavior to not treat all areas as document areas. Doing Window
> - Reset Windows is a workaround to get the IDE to have expected behavior
> (open source files in the main area), it is definitly not a fix. Everytime a
> user has to run that menu command, they have to go about putting the panes
> back where they prefer them. This behavior is not intuitive and it is
> frustrating. How many times will a user "reset windows" before they get
> frustrated and switch to another IDE that behaves as they expect it to?
> 
> Experienced on Netbeans 7.4 (OS X)

Get the latest build and run it with -J-DNB.WinSys.Mix.Editors.And.Views.Enabled=false command-line switch. It will disable mixing of document and non-document windows.
When NB 8.0 is released I'll provide a plugin to configure this behavior in Options window.
Comment 7 jonsapp 2014-09-22 18:06:36 UTC
I had this same problem.
Turned out my navigator had closed.
Hit control+7 and move you projects pane into the navigator.
Now you files should open in the editor again.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo