Bug 213707 - CodeCompletion took 2077 ms.
CodeCompletion took 2077 ms.
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 06:34 UTC by crazyjavahacking
Modified: 2012-06-07 07:56 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (23.27 KB, application/nps)
2012-06-07 06:34 UTC, crazyjavahacking
Details

Note You need to log in before you can comment on or make changes to this bug.
Description crazyjavahacking 2012-06-07 06:34:06 UTC
This bug was originally marked as duplicate of bug 197270, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201206050001)
VM: Java HotSpot(TM) Client VM, 20.7-b02, Java(TM) SE Runtime Environment, 1.6.0_32-b05
OS: Windows 7

User Comments:
crazyjavahacking: Mockito code completion



Maximum slowness yet reported was 2077 ms, average is 2077
Comment 1 crazyjavahacking 2012-06-07 06:34:13 UTC
Created attachment 120457 [details]
nps snapshot
Comment 2 Tomas Danek 2012-06-07 07:35:32 UTC
passing to code completion, but snapshot is probably shorter than it should be.
Comment 3 Dusan Balek 2012-06-07 07:56:27 UTC
As can be seen from the attached snapshot, the code completion thread is waiting for the slow IO (java.io.WinNTFileSystem.getBooleanAttributes())


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo