Bug 213563 - IllegalArgumentException: URI has an authority component
IllegalArgumentException: URI has an authority component
Status: RESOLVED DUPLICATE of bug 213562
Product: apisupport
Classification: Unclassified
Component: Project
7.2
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 19:13 UTC by Jesse Glick
Modified: 2012-06-13 14:22 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.03 KB, text/plain)
2012-06-04 19:13 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-06-04 19:13:45 UTC
Build: NetBeans IDE Dev (Build 20120604-0da85416d886)
VM: Java HotSpot(TM) Client VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows XP

Stacktrace: 
java.lang.IllegalArgumentException: URI has an authority component
   at java.io.File.<init>(File.java:397)
   at org.netbeans.modules.apisupport.project.queries.UpdateTrackingFileOwnerQuery.getOwner(UpdateTrackingFileOwnerQuery.java:76)
   at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:150)
   at org.netbeans.modules.java.project.ProjectSourceForBinaryQuery.findSourceRoots(ProjectSourceForBinaryQuery.java:67)
   at org.netbeans.api.java.queries.SourceForBinaryQuery.findSourceRoots(SourceForBinaryQuery.java:96)
   at org.netbeans.api.java.source.SourceUtils.getFile(SourceUtils.java:509)
Comment 1 Jesse Glick 2012-06-04 19:13:51 UTC
Created attachment 120340 [details]
stacktrace
Comment 2 Jesse Glick 2012-06-13 14:22:36 UTC
Probably already fixed.

*** This bug has been marked as a duplicate of bug 213562 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo