Bug 213351 - IllegalArgumentException: URI has an authority component
IllegalArgumentException: URI has an authority component
Status: RESOLVED DUPLICATE of bug 213562
Product: apisupport
Classification: Unclassified
Component: Project
7.2
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 23:34 UTC by Jesse Glick
Modified: 2012-06-06 21:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.20 KB, text/plain)
2012-05-31 23:34 UTC, Jesse Glick
Details
stacktrace (1.20 KB, text/plain)
2012-06-04 19:04 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-05-31 23:34:41 UTC
Build: NetBeans IDE Dev (Build 20120531-962cece4032b)
VM: Java HotSpot(TM) Client VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows XP

Stacktrace: 
java.lang.IllegalArgumentException: URI has an authority component
   at java.io.File.<init>(File.java:397)
   at org.netbeans.modules.apisupport.project.queries.UpdateTrackingFileOwnerQuery.getOwner(UpdateTrackingFileOwnerQuery.java:76)
   at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:150)
   at org.netbeans.modules.java.project.ProjectBinaryForSourceQuery.findBinaryRoots(ProjectBinaryForSourceQuery.java:68)
   at org.netbeans.api.java.queries.BinaryForSourceQuery.findBinaryRoots(BinaryForSourceQuery.java:91)
   at org.netbeans.modules.java.source.usages.BuildArtifactMapperImpl.getTarget(BuildArtifactMapperImpl.java:205)
Comment 1 Jesse Glick 2012-05-31 23:34:45 UTC
Created attachment 120169 [details]
stacktrace
Comment 2 Jesse Glick 2012-06-04 19:04:15 UTC
Created attachment 120338 [details]
stacktrace

Opening project from UNC path.
Comment 3 Jesse Glick 2012-06-06 21:01:56 UTC
Will be fixed as part of bug #213562.

*** This bug has been marked as a duplicate of bug 213562 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo