Bug 211994 - freeze when "Go to Source"
freeze when "Go to Source"
Status: RESOLVED WORKSFORME
Product: javaee
Classification: Unclassified
Component: JSP Parser
7.1.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Petr Hejl
issues@javaee
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 06:24 UTC by Marian Petras
Modified: 2015-06-25 15:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread-dump (27.58 KB, text/plain)
2012-05-03 06:24 UTC, Marian Petras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2012-05-03 06:24:47 UTC
Created attachment 118998 [details]
thread-dump

Just after startup, I had several JSP files open. In one of them, I Ctrl-clicked on a reference to another JSP file. After a while, dialogue "Lengty operation in progress" appeared, with text "Go to Source" (scanning of projects was not finished yet). The progress of the Scanning projects task stopped, i.e. the task did not continue (0% CPU usage) and the dialogue "Lengthy operation..." never disappeared. I tried to cancel the operation by clicking the Cancel button in the dialogue but NetBeans did not react.

After a while, I used JVisualVM to generate a thread-dump - see the attachment.

--
NetBeans 7.1.1
Windows 7 64-bit
JDK 6u32 64-bit
quad-core Intel CPU
Comment 1 Petr Hejl 2015-06-25 14:43:23 UTC
I do not see any explicit deadlock. Is this still reproducible?
Comment 2 Marian Petras 2015-06-25 15:55:25 UTC
I did not report a deadlock. I reported a freeze. From the thread-dump, it rather looks like a starvation - a thread invokes wait() but no other thread awakes it so the thread keeps waiting forever. Because the waiting thread was "AWT-EventQueue-1", the IDE stopped processing UI events.

Regarding the question about reproducibility:
It is difficult to reproduce issues caused by bad locking and/or synchronization. I can only say that I have not seen the bug since the day I reported it.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo