Bug 211930 - "Attribute "unless" was already specified" in osgi.xml
"Attribute "unless" was already specified" in osgi.xml
Status: RESOLVED DUPLICATE of bug 210524
Product: apisupport
Classification: Unclassified
Component: Harness
7.2
PC Windows 7
: P2 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 06:32 UTC by mienamoo
Modified: 2012-05-02 15:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mienamoo 2012-05-02 06:32:21 UTC
NetBeans build 201204220400
JDK 7u3 32-bit

When executing any of the OSGi context menu actions on an Ant-based platform suite project ("Run in Felix" for example), the following error in osgi.xml is pointed out:

C:\Program Files (x86)\NetBeans Dev 201204220400\harness\suite.xml:542: The following error occurred while executing this line:
C:\Program Files (x86)\NetBeans Dev 201204220400\harness\osgi.xml:174: Attribute "unless" was already specified for element "target".

The workaround is of course to edit the .xml file, but that is not ideal.
Comment 1 Jesse Glick 2012-05-02 15:35:48 UTC
Use a newer dev build.

*** This bug has been marked as a duplicate of bug 210524 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo