Bug 211734 - Install update of Autoupdate with other updates together unless Autoupdate doesn't need to be the first
Install update of Autoupdate with other updates together unless Autoupdate do...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Jiri Rechtacek
au-issues
: API, API_REVIEW_FAST
: 209561 (view as bug list)
Depends on: 212218
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 19:32 UTC by Jiri Rechtacek
Modified: 2012-05-25 12:22 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2012-04-25 19:32:09 UTC
Add a new flag into info.xml to specify if update of AU has to be installed before other updates or not. This flag will be off as default.
Comment 1 Jiri Rechtacek 2012-05-07 17:37:29 UTC
core-main/rev/2ff166910dfb, core-main/rev/1f6106c3e62c, core-main/rev/a71967b084bb on autoupdate_211777 branch

Need to add two DTD on http://netbeans.org/dtds and update http://netbeans.org/dtds/catalog
What this nbbuild/antsrc/org/netbeans/nbbuild/AutoUpdateCatalogParser.java?
Comment 2 Quality Engineering 2012-05-17 15:41:45 UTC
Integrated into 'main-golden', will be available in build *201205170950* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/2ff166910dfb
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #211734: Install update of Autoupdate with other updates together unless Autoupdate doesn't need to be the first
Comment 3 Marian Mirilovic 2012-05-25 12:22:06 UTC
*** Bug 209561 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo