Bug 211730 - Netbeans now creates empty names for every binding. This forces a runtime error due to duplicate names (i.e. multiple bindings with the name "").
Netbeans now creates empty names for every binding. This forces a runtime err...
Status: RESOLVED FIXED
Product: guibuilder
Classification: Unclassified
Component: Binding
7.1.1
PC Windows 7 x64
: P3 (vote)
: 7.4
Assigned To: issues@guibuilder
issues@guibuilder
: JDK_1.7, PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 17:17 UTC by rhizomorph
Modified: 2013-08-16 14:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rhizomorph 2012-04-25 17:17:45 UTC
For some reason, every time I create a new property binding now through the form editor, Netbeans automatically give the new binding a name of "". It never used to create names unless the designer explicitely typed one into the Name field on the Advanced tab. Now it creates empty names for every binding. The problem is that, when the program is run, it crashes due to there being a duplicate name (i.e. multiple bindings with the name ""). This means that in order to run my program, I have to explicitely provide unique binding names for every single binding in my program. It's time consuming and pointless since a name is not even required.

Product Version = NetBeans IDE 7.1.1 (Build 201202271535)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_02
Runtime = Java HotSpot(TM) 64-Bit Server VM 22.0-b10
Comment 1 Jan Stola 2013-01-08 16:10:08 UTC
This seems to be some subtle (but annoying) problem of String in-place editor. I was able to reproduce this issue on JDK 7 only, it works fine on JDK 6. The empty name of the binding is set when you switch to the Advanced tab of the binding customizer and when the Name field gets a focus.
Comment 2 Tomas Pavek 2013-08-16 14:36:27 UTC
I think we can consider empty string as no name. I've made a fix that does that. So if there is an empty string (whether set accidentally or knowingly), it is converted to null. I also noticed that canceling the dialog did not restore the original values correctly (if editing existing binding and changing some values not set before - then after cancel they were actually set).

http://hg.netbeans.org/jet-main/rev/17f7dceff2f7


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo