Bug 2114 - Solaris: Deadlock when Compile All action is invoked on package.
Solaris: Deadlock when Compile All action is invoked on package.
Status: CLOSED WORKSFORME
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
All Other
: P1 (vote)
: TBD
Assigned To: issues@www
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-08 01:34 UTC by issues@www
Modified: 2008-12-23 10:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description issues@www 1999-06-08 01:34:37 UTC
I compiled package containing files for EJB. Sometimes Compile All action freezes IDE. It is reproducible although it occurs on more retries.

Tested using Solaris production JDKs 1.2.1 (02) and JDK 1.2.1 RC (03).

-- System info ----------------------------------------------------------------
  Product Version    = NetBeans Developer (Gandalf), Build 332
  IDE Versioning     = IDE/1 spec=0.9 impl=Build 332
  Operating System   = SunOS Version 5.7 Running on sparc
  Java VM Version    = 1.2.1
  Java Vendor        = Sun Microsystems Inc.

  Java Vendor URL    = http://www.sun.com/
  Java Home          = /usr/jdk1.2.1_03_pre/jre
  Java Class Version = 46.0
  JIT                = NONE
  Home Dir           = /home/mbalin
  Current Directory  = /qa/corona_332
  NetBeans Home      = .
  NetBeans User Home = .
  System Directory   = ./system
  CLASSPATH          = ./lib:./lib/developer.jar:./lib/xml.jar:/usr/jdk1.2.1_03_pre/jre/lib/i18n.jar:/usr/jdk1.2.1_03_pre/lib/tools.jar:/usr/jdk1.2.1_03_pre/lib/dt.jar
-------------------------------------------------------------------------------

FOUND A JAVA LEVEL DEADLOCK:
---------------------------
t@132 waiting to lock object@0x12fe770:"com/netbeans/ide/filesystems/DefaultAttributes"
         which is locked by t@8
t@8 waiting to lock object@0xf5fc0f1c:"com/netbeans/ide/filesystems/AbstractFileObject"
         which is locked by t@132

JAVA STACK INFORMATION FOR THREADS LISTED ABOVE:
-----------------------------------------------

Java Stack for t@132 (EE = 0x128d888) "Thread-9" :

==========
[1] com.netbeans.ide.filesystems.DefaultAttributes.readAttribute(DefaultAttributes.java:123)
[2] com.netbeans.ide.filesystems.AbstractFileObject.getAttribute(AbstractFileObject.java:299)
[3] com.netbeans.ide.loaders.DataLoaderPool.findDataObject(DataLoaderPool.java:330)
[4] com.netbeans.ide.loaders.FolderList.createBoth(FolderList.java:366)
[5] com.netbeans.ide.loaders.FolderList.refresh(FolderList.java:
Comment 1 Quality Engineering 2003-07-02 14:55:44 UTC
Resolved for 3.4.x or earlier, no new info since then -> verify.
Comment 2 Quality Engineering 2003-07-02 15:13:35 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo