Bug 211121 - "Executing SQL statement(s)" progress bar hanging in the status bar even after mySql service has been restarted.
"Executing SQL statement(s)" progress bar hanging in the status bar even afte...
Status: RESOLVED DUPLICATE of bug 159929
Product: db
Classification: Unclassified
Component: Code
7.1.1
PC Linux
: P3 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 21:19 UTC by holobeat
Modified: 2012-04-16 10:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description holobeat 2012-04-12 21:19:59 UTC
Product Version = NetBeans IDE 7.1.1 (Build 201203012225)
Operating System = Linux version 3.0.0-16-generic running on i386
Java; VM; Vendor = 1.6.0_26
Runtime = Java HotSpot(TM) Client VM 20.1-b02

When executing a long running SQL query, an attempt to cancel the running query (clicking "X" in the status bar) does not do anything. Even after restarting the mySql service, the "Executing SQL statement(s)" progress bar is still hanging in the status bar. Still, the CPU seems to be running on 50%. Only restarting the IDE will set back to normal.
Comment 1 Marian Mirilovic 2012-04-16 08:51:27 UTC
I think we already have such issue in BugZilla ...
Comment 2 matthias42 2012-04-16 10:47:17 UTC
You are right - this is a long standing issue (and today a collegue was biten by this bug). The issue is not 100% the same, but the cause is (not being able to cancel a statement correctly). For hanging at 50% CPU seems to be another issue or a bug in the underlying jdbc driver.

*** This bug has been marked as a duplicate of bug 159929 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo