Bug 210393 - Netbeans runs it's own cache, not just compiled sources
Netbeans runs it's own cache, not just compiled sources
Status: NEW
Product: java
Classification: Unclassified
Component: Compiler
7.1
PC Linux
: P3 with 1 vote (vote)
: 7.2
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 16:48 UTC by Koyotter
Modified: 2012-04-04 14:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Koyotter 2012-03-29 16:48:34 UTC

    
Comment 1 Koyotter 2012-03-29 17:01:33 UTC
After an upgrade to Netbeans 7.1 from netbeans 7.0.1, we have a bug in 2 computers, platform - Windows 7 and Linux Slackware.

A bug is -  that clean/build project was successful, but after that, while running Java-project, we've got some exceptions - the first was NullPointerException. but in click on it in the log window, 
the editor opens a place in code, where no any method body!
That error occured on mine (Linux) ant my colleague's (Windows ) 2 PC's. 
We tried to do the following:
 recompile project (clean and build);
 delete ./netbeans in home directory;
 reinstall netbeans;
 re-checkout our Java sources from repository;
and much more. There was no effect.
I build the project by Ant from the command line, and then run from the command line withowt any error. Errors are only in netbeans, which runs unexisting and unactual code!!!

What is the CACHE in netbeans???

Now we are temporarily using Eclipse, and don't know how it happened. Netbeans are much more nice for us!
Comment 2 Dusan Balek 2012-03-30 08:29:11 UTC
Have you tried to switch the 'Compile On Save' off for your project (Project->Properties->Build->Compiling)?
Comment 3 Koyotter 2012-03-31 14:34:11 UTC
(In reply to comment #2)
> Have you tried to switch the 'Compile On Save' off for your project
> (Project->Properties->Build->Compiling)?

Yes, we did it some times. 

I remember - it was so when we upgraded netbeans to version 7.0.1. 
There was the same problem, but this action helped us.
Unfortunately, now in version 7.1.1 there was no effect.
Comment 4 Jiri Prox 2012-04-04 14:30:32 UTC
I've seen it as well. But I cannot figure out reliable steps to reproduce. It usually happens when I'm running single class and changing some String literals.

Disabling COS helps


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo