Bug 209556 - NullPointerException at org.netbeans.modules.subversion.ui.repository.Repository.onSelectedRepositoryChange
NullPointerException at org.netbeans.modules.subversion.ui.repository.Reposit...
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Ondrej Vrabec
issues@versioncontrol
EXCEPTIONS_REPORT
:
: 215392 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 08:02 UTC by schkovich
Modified: 2012-07-27 09:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.74 KB, text/plain)
2012-03-14 08:02 UTC, schkovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-03-14 08:02:47 UTC
Build: NetBeans IDE Dev (Build 201203120400)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Going over file changes through history editor




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.subversion.ui.repository.Repository.onSelectedRepositoryChange(Repository.java:400)
   at org.netbeans.modules.subversion.ui.repository.Repository.initPanel(Repository.java:221)
   at org.netbeans.modules.subversion.ui.repository.Repository.<init>(Repository.java:133)
   at org.netbeans.modules.subversion.client.SvnClientExceptionHandler.handleRepositoryConnectError(SvnClientExceptionHandler.java:233)
   at org.netbeans.modules.subversion.client.SvnClientExceptionHandler.handleException(SvnClientExceptionHandler.java:185)
   at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.handleException(SvnClientInvocationHandler.java:393)
Comment 1 schkovich 2012-03-14 08:02:49 UTC
Created attachment 116700 [details]
stacktrace
Comment 2 Ondrej Vrabec 2012-03-14 08:54:13 UTC
The thread normally displaying the authentication dialog receives an interrupt and this results in the exception in the dialog's initializer.
Comment 3 Ondrej Vrabec 2012-03-14 08:55:09 UTC
fix: http://hg.netbeans.org/core-main/rev/08bca38a9e1f
Comment 4 Quality Engineering 2012-03-17 10:37:08 UTC
Integrated into 'main-golden', will be available in build *201203170400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/08bca38a9e1f
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #209556 - NullPointerException at org.netbeans.modules.subversion.ui.repository.Repository.onSelectedRepositoryChange
Comment 5 Ondrej Vrabec 2012-07-27 09:31:47 UTC
*** Bug 215392 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo