Bug 209422 - AssertionError in FileObject.toURI: file:////ZARATUSTRA/Projects/Baulux/HTML%20(new)/ from \\ZARATUSTRA\Projects\Baulux\HTML (new)@687b7f23:18feba
AssertionError in FileObject.toURI: file:////ZARATUSTRA/Projects/Baulux/HTML%...
Status: RESOLVED DUPLICATE of bug 207060
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 08:44 UTC by KhArtNJava
Modified: 2012-03-26 19:57 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.92 KB, text/plain)
2012-03-11 08:44 UTC, KhArtNJava
Details
snapshot with exception (27.80 KB, application/octet-stream)
2012-03-11 08:48 UTC, KhArtNJava
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KhArtNJava 2012-03-11 08:44:49 UTC
Build: NetBeans IDE Dev (Build 201203100400)
VM: Java HotSpot(TM) Client VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

User Comments:
GUEST: opening .php file

KhArtNJava: when I am try to open html file

GUEST: Opening every file throws this exception




Stacktrace: 
java.lang.AssertionError: file:////ZARATUSTRA/Projects/Baulux/HTML%20(new)/ from \\ZARATUSTRA\Projects\Baulux\HTML (new)@687b7f23:18feba
   at org.openide.filesystems.FileObject.toURI(FileObject.java:1165)
   at org.netbeans.modules.projectapi.SimpleFileOwnerQueryImplementation.getOwner(SimpleFileOwnerQueryImplementation.java:145)
   at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:104)
   at org.netbeans.modules.projectapi.ProjectFileEncodingQueryImplementation.getEncoding(ProjectFileEncodingQueryImplementation.java:66)
   at org.netbeans.api.queries.FileEncodingQuery.getEncoding(FileEncodingQuery.java:94)
   at org.netbeans.modules.html.HtmlDataObject$FileEncodingQueryImpl.getEncoding(HtmlDataObject.java:356)
Comment 1 KhArtNJava 2012-03-11 08:44:52 UTC
Created attachment 116543 [details]
stacktrace
Comment 2 KhArtNJava 2012-03-11 08:48:47 UTC
Created attachment 116544 [details]
snapshot with exception

snapshot with exception
Comment 3 Jaroslav Tulach 2012-03-16 15:56:00 UTC
Jesse, this is a bug in your new code.
Comment 4 Jesse Glick 2012-03-26 19:57:09 UTC

*** This bug has been marked as a duplicate of bug 207060 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo