Bug 208774 - IllegalArgumentException: Comparison method violates its general contract!
IllegalArgumentException: Comparison method violates its general contract!
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: History
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Tomas Stupka
issues@versioncontrol
EXCEPTIONS_REPORT
:
: 210287 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 02:50 UTC by schkovich
Modified: 2012-04-20 10:10 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (8.60 KB, text/plain)
2012-02-23 02:50 UTC, schkovich
Details
stacktrace (3.01 KB, text/plain)
2012-03-27 14:41 UTC, javydreamercsw
Details
stacktrace (3.01 KB, text/plain)
2012-03-30 09:05 UTC, aldobrucale
Details
stacktrace (3.01 KB, text/plain)
2012-04-07 14:02 UTC, schkovich
Details
stacktrace (3.01 KB, text/plain)
2012-04-07 14:05 UTC, schkovich
Details
stacktrace (3.01 KB, text/plain)
2012-04-17 22:35 UTC, Exceptions Reporter
Details
stacktrace (3.01 KB, text/plain)
2012-04-18 10:38 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-02-23 02:50:29 UTC
Build: NetBeans IDE Dev (Build 201202220400)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Exception thrown after code completion of function var_dump, although it seams that action is not related to exception. :)




Stacktrace: 
java.lang.IllegalArgumentException: Comparison method violates its general contract!
   at java.util.ComparableTimSort.mergeLo(ComparableTimSort.java:714)
   at java.util.ComparableTimSort.mergeAt(ComparableTimSort.java:451)
   at java.util.ComparableTimSort.mergeCollapse(ComparableTimSort.java:374)
   at java.util.ComparableTimSort.sort(ComparableTimSort.java:182)
   at java.util.Arrays.sort(Arrays.java:537)
   at java.util.TimSort.sort(TimSort.java:178)
Comment 1 schkovich 2012-02-23 02:50:31 UTC
Created attachment 116044 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-03-02 15:00:48 UTC
Coming from: versioning.ui.history.HistoryRootNode.addEntries(HistoryRootNode.java:134)
Comment 3 javydreamercsw 2012-03-27 14:41:17 UTC
Created attachment 117342 [details]
stacktrace

Pasted code into editor.
Comment 4 aldobrucale 2012-03-30 09:05:20 UTC
Created attachment 117531 [details]
stacktrace

Moved up a java line of code with ctrl-shift-up
Comment 5 schkovich 2012-04-07 14:02:20 UTC
Created attachment 117976 [details]
stacktrace

overtyping selected text in php editor
Comment 6 Exceptions Reporter 2012-04-07 14:02:33 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=185296
Comment 7 schkovich 2012-04-07 14:05:22 UTC
Created attachment 117977 [details]
stacktrace

paste text in php editor
Comment 8 Exceptions Reporter 2012-04-07 14:05:46 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=185296
Comment 9 Tomas Stupka 2012-04-11 12:11:37 UTC
*** Bug 210287 has been marked as a duplicate of this bug. ***
Comment 10 Exceptions Reporter 2012-04-17 22:35:27 UTC
Created attachment 118425 [details]
stacktrace

Editing a CSS file.
Comment 11 Exceptions Reporter 2012-04-18 10:38:25 UTC
Created attachment 118444 [details]
stacktrace

Editing a php file
Comment 12 Tomas Stupka 2012-04-18 17:51:37 UTC
fixed in core-main #dfe53fbd9879
Comment 13 Quality Engineering 2012-04-20 10:10:40 UTC
Integrated into 'main-golden', will be available in build *201204200400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/dfe53fbd9879
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #208774 - IllegalArgumentException: Comparison method violates its general contract!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo