Bug 208623 - [71cat] NullPointerException at org.netbeans.modules.versioning.DelegatingVCS$DelegatingHistoryProvider.getHistory
[71cat] NullPointerException at org.netbeans.modules.versioning.DelegatingVCS...
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.2
All All
: P3 (vote)
: TBD
Assigned To: Tomas Stupka
issues@versioncontrol
EXCEPTIONS_REPORT
:
: 208827 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-20 07:55 UTC by schkovich
Modified: 2012-03-01 18:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (891 bytes, text/plain)
2012-02-20 07:55 UTC, schkovich
Details
stacktrace (891 bytes, text/plain)
2012-03-01 13:19 UTC, Exceptions Reporter
Details
stacktrace (891 bytes, text/plain)
2012-03-01 18:31 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-02-20 07:55:27 UTC
Build: NetBeans IDE Dev (Build 201202190400)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Exception was thrown on clicking on history tab of previously renamed php file.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.versioning.DelegatingVCS$DelegatingHistoryProvider.getHistory(DelegatingVCS.java:577)
   at org.netbeans.modules.versioning.ui.history.HistoryFileView$2.run(HistoryFileView.java:225)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1404)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1984)
Comment 1 schkovich 2012-02-20 07:55:30 UTC
Created attachment 115932 [details]
stacktrace
Comment 2 Exceptions Reporter 2012-02-26 19:14:44 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=185110
Comment 3 Tomas Stupka 2012-02-27 10:55:29 UTC
*** Bug 208827 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Stupka 2012-02-27 12:38:31 UTC
fixed in core-main #489336679a89
Comment 5 KhArtNJava 2012-02-28 06:24:03 UTC
Error reproduced in the IDE Build 201202270400.
Comment 6 KhArtNJava 2012-02-28 07:15:20 UTC
Hello
You wrote
fixed in core-main # 489336679a89

Today I downloaded the IDE Build 201202270400 and reproduced the error.
I would like to know when changes are applied in core-main #
489336679a89 will be available in nightly builds?

Best regards, Arthur.
Comment 7 Tomas Stupka 2012-02-28 07:36:15 UTC
> I would like to know when changes are applied in core-main #
> 489336679a89 will be available in nightly builds?
it usually doesn't take long until it is propagated to main-golden and when that happens it also will be notified in this issue
Comment 8 KhArtNJava 2012-02-28 07:38:20 UTC
Thank you for reply.
Comment 9 Quality Engineering 2012-03-01 10:59:09 UTC
Integrated into 'main-golden', will be available in build *201203010400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/489336679a89
User: Tomas Stupka <tstupka@netbeans.org>
Log: issue #208623 - [71cat] NullPointerException at org.netbeans.modules.versioning.DelegatingVCS$DelegatingHistoryProvider.getHistory
Comment 10 Exceptions Reporter 2012-03-01 13:19:08 UTC
Created attachment 116239 [details]
stacktrace

Only open history and select one item by right clic => cause nullPointerException.
Comment 11 KhArtNJava 2012-03-01 13:51:56 UTC
201203010400 - OK, no exceptions on text replacement in php files.
Comment 12 KhArtNJava 2012-03-01 13:54:16 UTC
Sorry, wrong number of issue - I wanted to write in another issue :(
Comment 13 KhArtNJava 2012-03-01 13:59:18 UTC
Now in 201203010400 I have another exception:
http://statistics.netbeans.org/analytics/exception.do?id=563093
Comment 14 Exceptions Reporter 2012-03-01 18:31:09 UTC
Created attachment 116260 [details]
stacktrace

Opening History for versioned file


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo