Bug 207962 - Regress"Export To" of selfsampler snapshot buggy
Regress"Export To" of selfsampler snapshot buggy
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
7.2
PC All
: P3 (vote)
: 7.1.2
Assigned To: Petr Cyhelsky
issues@profiler
71patch2-verified
: VISUALVM
: 208963 210865 212402 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-31 17:19 UTC by mklaehn
Modified: 2012-09-26 12:28 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mklaehn 2012-01-31 17:19:22 UTC
After performing a self sampling I tried to store the created snapshot using the "Export to..." action. A file selection dialog opened where I selected a folder, entered a file name and pressed "Save".

Searching for the specified file can be irritating depending on what was entered as the file name.

If I enter "openNBPlatforms" a file named "null.nps" is created.
Bad.

But if I entered "openNBPlatforms.nps" a file named "openNBPlatforms.nps" is created.
Great just as expected.

When i compare both files ("null.nps" and "openNBPlatforms.nps") both seem to be binary identical except for a timestamp (which i guess is the timestamp of creating the snapshot).

My current environment:
Product Version: NetBeans IDE Dev (Build nbms-and-javadoc-8570-on-20120122)
Java: 1.6.0_26; Java HotSpot(TM) Server VM 20.1-b02
System: Windows XP version 5.1 running on x86; Cp1252; en (nb)

nbms-and-javadoc-8376-on-20111208 already has this issue
Comment 1 Petr Cyhelsky 2012-02-01 08:30:40 UTC
fixed in: http://hg.netbeans.org/profiler-main/rev/1c6eeabd23bdprofiler
Comment 2 Petr Cyhelsky 2012-02-01 08:36:03 UTC
correction: http://hg.netbeans.org/profiler-main/rev/1c6eeabd23bd
Comment 3 Tomas Hurka 2012-02-28 20:19:09 UTC
*** Bug 208963 has been marked as a duplicate of this bug. ***
Comment 4 Quality Engineering 2012-04-03 13:15:57 UTC
Integrated into 'releases', will be available in build *201204030956* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/dbecba7943dc
User: Petr Cyhelsky <cyhelsky@netbeans.org>
Log: #207962 do not throw away file name without extension when exporting snapshot
(transplanted from 1c6eeabd23bddca21f4b8ef2935aa300bf07cc60)
Comment 5 Tomas Hurka 2012-04-04 11:51:46 UTC
Transplanted to release71_fixes:
http://hg.netbeans.org/releases/rev/dbecba7943dc

http://hg.netbeans.org/releases/rev/c49ddb91fcf0
Comment 6 Petr Cyhelsky 2012-04-10 10:37:33 UTC
verified on:
Product Version: NetBeans IDE 7.1.2 (Build 201204052205)
Java: 1.7.0_04-ea; Java HotSpot(TM) 64-Bit Server VM 23.0-b20
System: Linux version 2.6.38-13-generic running on amd64; UTF-8; en_US (nb)
Comment 7 Petr Cyhelsky 2012-04-11 06:28:34 UTC
*** Bug 210865 has been marked as a duplicate of this bug. ***
Comment 8 J Bachorik 2012-05-11 16:48:46 UTC
*** Bug 212402 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo