Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 20794 - need help button in property sheet to resolve help ID confusion
need help button in property sheet to resolve help ID confusion
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
All All
: P3 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-22 16:14 UTC by John Jullion-ceccarelli
Modified: 2008-12-23 13:37 UTC (History)
10 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
test class (4.15 KB, text/plain)
2002-03-19 17:55 UTC, Jesse Glick
Details
Proposed patch (see also next attachment) (8.43 KB, patch)
2002-03-20 17:40 UTC, Jesse Glick
Details | Diff
Image to be placed in openide/src/org/openide/resources/propertysheet/help.gif (PROVISIONAL) (348 bytes, image/gif)
2002-03-20 17:41 UTC, Jesse Glick
Details
help button for toolbars (1.02 KB, image/gif)
2002-03-21 14:15 UTC, John Jullion-ceccarelli
Details
a binary patch for testing in orion builds (85.21 KB, application/octet-stream)
2002-03-22 14:33 UTC, Jiri Rechtacek
Details
a demonstration button (176 bytes, image/gif)
2002-03-26 13:05 UTC, Jiri Rechtacek
Details
disabled button (241 bytes, image/gif)
2002-03-27 02:08 UTC, Bruce Lee
Details
a new placeholder (371 bytes, image/gif)
2002-03-27 13:57 UTC, Jiri Rechtacek
Details
Help button (348 bytes, image/gif)
2002-03-27 17:55 UTC, Bruce Lee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Jullion-ceccarelli 2002-02-22 16:14:21 UTC
I know this issue has come up before, but it still hasn't been resolved. When 
you select a property sheet or any of its individual properties and press F1, 
the help system still displays help for the Explorer node whose properties are 
being displayed, and not for the property sheet. 

We'd like to resolve this by putting a help button in the property sheet 
toolbar which would only call the help ID for the property sheet or fronted 
tab.
Comment 1 Jesse Glick 2002-02-24 19:05:26 UTC
I am confused. This looks like two separate issues.

1. You say that the system for displaying help from the active
property sheet or property, where such help is set, is not working? If
so, that is a regression (DEFECT) to be filed in openide/explorer with
*exact* steps to reproduce on a small test case to make sure it gets
fixed and stays that way. If this is the case, please open a separate
issue, do not add comments here.

2. Request for a help button to be added to the property sheet, which
I will assume this issue is for. Need details of expected behavior:
should it always be present? Enabled or greyed out when there is no
specific help for properties of the node (only generally for the
node)? Also what should it do with property-specific help? Should it
attempt to find help for the property with focus, if any? What if not?
Etc. Also need an icon for the button, ask Bruce Lee I suppose.
Comment 2 John Jullion-ceccarelli 2002-02-28 18:30:54 UTC
Help button behavior:

1. Always present.
2. Enabled or greyed out depending on whether property sheet-level 
help is available.
3. Displays help for the fronted tab only. 
4. Doesn't look for property-level help. Right now this doesn't exist 
anyway, in the future we'll probably handle it with popups and What's 
This help cursor.

Icon's being worked on. Let me know if you need a working copy as a 
placeholder. Thanks.
Comment 3 Jesse Glick 2002-03-04 19:09:59 UTC
I really don't think a UI enhancement qualifies as 3.3.2_CANDIDATE.
3.3.2 fixes are supposed to be for critical bugs, which this hardly is
IMHO.
Comment 4 Patrick Keegan 2002-03-04 19:34:33 UTC
I back up the 3.3.2_CANDIDATE status, because AFAICT it is a low-risk fix with high 
value for docs. Also, late UI changes are discouraged largely because they make life 
harder for docs. This is a UI change that would make life better for docs.
Comment 5 Bob May 2002-03-12 18:34:05 UTC
I definitely think is a 3.3.2_CANDIDATE; while 3.3.2 is for critical
fixes, the button would add value to the IDE help's usability, and 
improved usability is one goal for Orion help. In addition, it is a
low-risk improvement.
Comment 6 Jan Chalupa 2002-03-19 14:21:06 UTC
Is anyone actively working on this issue? I understand that Docs would
like to see this implemented soon, but I'm not sure if it's complete
from the design point of view and if something is going to implement
the necessary logic in the property sheet. Is HIE aware of this issue?
Are you guys fine with the proposed solution?
Comment 7 Jesse Glick 2002-03-19 17:54:25 UTC
I have a working patch for this in the trunk, will attach when I get a chance. Seems to work fine. For 
now, attaching a sample class which is useful for demoing different kinds of help IDs; drop in correct 
package, compile against openide.jar, run with Internal Execution.
Comment 8 Jesse Glick 2002-03-19 17:55:09 UTC
Created attachment 5100 [details]
test class
Comment 9 Jesse Glick 2002-03-20 17:40:02 UTC
Created attachment 5118 [details]
Proposed patch (see also next attachment)
Comment 10 Jesse Glick 2002-03-20 17:41:41 UTC
Created attachment 5119 [details]
Image to be placed in openide/src/org/openide/resources/propertysheet/help.gif (PROVISIONAL)
Comment 11 Jesse Glick 2002-03-20 17:49:17 UTC
Jirko, as property sheet owner do you want to take over from here? 
I.e. review the proposed patch, commit to trunk, and commit this or a 
similar patch to orion_fcs (with INF and setting milestone to FFJ 4.0 
etc.). With JavaOne etc. approaching I am not sure I can physically 
get this committed myself, but the attached patch seems to work fine 
in the trunk and meets John's design requirements 1-4. There are 
probably small changes that need to be made to work against release33 
code, but I believe the basic code involved here is similar.

Note that a final icon should be provided (Bruce Lee?) before 
committing to orion_fcs, to avoid the need to make a second 
integration later.

I tested the patch only with the previously attached test class. I 
know there are a couple of real features in the IDE that use 
sheet-level help (WEB-INF objects??) but was not sure how to actually 
use them in the UI so as to test.
Comment 12 Jan Chalupa 2002-03-20 17:53:58 UTC
I'm still looking for HIE's opinion on this. I'm told that the
property sheet toolbar is going to disappear entirely in NB 3.4. If
this is really the case, does it make sense to add more buttons to it
in 3.3.x?
Comment 13 Jesse Glick 2002-03-20 18:01:34 UTC
Good question - should probably be brought up on nbui. If e.g. the 
toolbar were replaced by a popup menu available in the property sheet, 
then "Help" would be a menu item there, I guess. Maybe "Help on 
Properties" or "Help on Expert", or if applicable "Help on Name" if 
you right-click on the "Name" row.
Comment 14 Paul Fussell 2002-03-20 18:11:41 UTC
Yes, it makes sense to add the Help button now because Netbeans 3.3.2 
will be the basis for the upcoming release of Forte for Java 4.0, a 
product that will be sold to customers for about a year and will not 
have the benefits of changes to Netbeans 3.4. The usability problem 
of discovering and then getting help for property sheets has been an 
issue for over two years now, and if it is not solved in 3.3.2, it 
will continue to be a problem for paying customers for at least 
another year.
Comment 15 Jesse Glick 2002-03-20 18:37:33 UTC
Given the comments made here, a P2 priority may be more appropriate 
than P3...
Comment 16 Jan Benway 2002-03-20 23:57:13 UTC
Hmm. HIE isn't aware of a plan to remove the toolbar from the
properties sheet in 3.4. At least, I'm not and Dirk Ruiz is not.
Perhaps *that* should be brought up on nbui before we start worrying
about how it would affect a help button.
Comment 17 Jan Chalupa 2002-03-21 08:35:09 UTC
The issue was filed on 2/22/2002 as a P3 defect (2 days later changed
to 'enhancement'). 

If the users have been suffering so badly for two years and if it's so
urgent, why hasn't it been reported earlier? Why didn't it appear on
the 3.3 requirements list? Why is it a P3?

The policy we've been following for dot-dot releases so far says "No
new features. Bug fixes only". This issue doesn't seem to meet this
criteria. 


Comment 18 John Jullion-ceccarelli 2002-03-21 14:15:04 UTC
Created attachment 5134 [details]
help button for toolbars
Comment 19 John Jullion-ceccarelli 2002-03-21 14:17:04 UTC
Jesse, please use the icon I attached for the help button. 
Let me know if you need a greyed out version for when help 
is unavailable.
Comment 20 Jiri Rechtacek 2002-03-21 17:11:17 UTC
Implemented in main trunk. Waited for conclusion for integrate in
orion_fcs and for final design of help button.
Comment 21 Jiri Rechtacek 2002-03-22 10:04:43 UTC
fixed in the main trunk
Comment 22 Jiri Rechtacek 2002-03-22 14:33:12 UTC
Created attachment 5148 [details]
a binary patch for testing in orion builds
Comment 23 Jiri Rechtacek 2002-03-22 14:41:02 UTC
I have attached a jar file with patch. You can copy this file to
<ide_home>/lib/patches and test a cooperation with module which
provide the help ids for property sheets. Warning: the button for help
 is only temporary and it is waited for redesign and more it is
usually disabled because the most modules don't provide the help ids
for property sheet.
Comment 24 Patrick Keegan 2002-03-22 14:49:55 UTC
Paul, since this largely affects your modules, you could test this 
patch in an orion build?
Comment 25 Bruce Lee 2002-03-25 21:30:21 UTC
I have not installed the patch and tested it, but I'm not sure I
understand what is needed graphically. But I looked at the icon that
John posted, and then checked with Jan Benway. This, we agree is the
icon to use for this purpose. So I need to know what the graphics
issues are. Icon too jaggy? Need disabled version? Too big? Too small?
I just need to know specifically what is needed and I'll be happy to
do it.
Comment 26 Marian Mirilovic 2002-03-26 09:13:31 UTC
Ok, Bruce see :

issue 21789 and issue 21794.
Comment 27 Jiri Rechtacek 2002-03-26 13:03:14 UTC
The issues about help button are based on wrong size of icon firstly.
Help button has 24x24px size w/o transparency background, the others
button on property sheet panel have 16x16px size w/ transparency
background. There is only one icon  for each button; switching
enabled/disabled state is performed by
swing.AbstractButton.setEnabled(boolean). I'm going to attach
customize button's icon e.g. you can look on. I hope this information
helps.
Comment 28 Jiri Rechtacek 2002-03-26 13:05:51 UTC
Created attachment 5188 [details]
a demonstration button
Comment 29 Bruce Lee 2002-03-27 02:08:49 UTC
Created attachment 5195 [details]
disabled button
Comment 30 Bruce Lee 2002-03-27 02:14:02 UTC
Added attachment for disabled icon, by request. But remember,disabled
icons are done in the rest of the IDE by putting a gray alpha channel
over the icon. I think we should match the same method for this button
also, so we don't become a special case. If this prooves too
difficult, or can't be done in the time alloted, use the icon in the
attachment.
best,
b. 
Comment 31 Jiri Rechtacek 2002-03-27 13:53:20 UTC
sorry, but it is pretty misunderstanding. We do not want a disabled
icon but a icon for help button in property toolbar with right *size*
and *transparent* background. I'm going attach new placeholder
(reworked a little), it is fixed in main trunk. It could used in
orion_fcs branch IMHO. Bruce look on it pls. for review it is
acceptable. I assign issue about this icon on Bruce.
Comment 32 Jiri Rechtacek 2002-03-27 13:57:28 UTC
Created attachment 5206 [details]
a new placeholder
Comment 33 Bruce Lee 2002-03-27 17:55:24 UTC
Created attachment 5216 [details]
Help button
Comment 34 Bruce Lee 2002-03-27 17:57:05 UTC
Sorry Jiri,
I posted this to another list. (there are three or four threads going
on about this now) and thought you had the original. Just posted it.
If you need anything else, please post.
best,
b.
Comment 35 Jiri Rechtacek 2002-03-27 18:25:43 UTC
thanks, this icon is fine (especially about size and transparency).
I'm suppose it is final resolution I'm going to ask for approval for
integrate to orion_fcs.
Comment 36 Jiri Rechtacek 2002-03-28 12:08:26 UTC
commited to orion_fcs branch
Comment 37 Jan Chalupa 2002-03-29 13:35:50 UTC
Verified in build 20020328.
Comment 38 Marian Mirilovic 2002-04-02 10:13:19 UTC
verified in [orion_CE](20020401) && [jdk1.3.1](03)/[jdk1.4](fcs)
Comment 39 Marian Mirilovic 2002-04-02 10:33:00 UTC
It works for example for node :
Session (EJB)
Comment 40 Quality Engineering 2003-07-01 16:31:58 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo