Bug 207648 - AssertionError: memory://fs3//
AssertionError: memory://fs3//
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Jesse Glick
issues@platform
EXCEPTIONS_REPORT
:
: 207654 (view as bug list)
Depends on:
Blocks: 207294
  Show dependency treegraph
 
Reported: 2012-01-23 19:36 UTC by Jesse Glick
Modified: 2012-01-25 16:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.96 KB, text/plain)
2012-01-23 19:36 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-01-23 19:36:43 UTC
Build: NetBeans IDE Dev (Build 20120123-ed35647923ed)
VM: Java HotSpot(TM) Client VM, 22.0-b10, Java(TM) SE Runtime Environment, 1.7.0_02-b13
OS: Linux

Stacktrace: 
java.lang.AssertionError: memory://fs3//
   at org.openide.filesystems.FileObject.toURI(FileObject.java:1165)
   at org.netbeans.modules.projectapi.SimpleFileOwnerQueryImplementation.getOwner(SimpleFileOwnerQueryImplementation.java:145)
   at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:104)
   at org.netbeans.modules.projectapi.ProjectFileEncodingQueryImplementation.getEncoding(ProjectFileEncodingQueryImplementation.java:66)
   at org.netbeans.api.queries.FileEncodingQuery.getEncoding(FileEncodingQuery.java:94)
   at org.netbeans.modules.parsing.api.Source.createSnapshot(Source.java:316)
Comment 1 Jesse Glick 2012-01-23 19:36:46 UTC
Created attachment 115171 [details]
stacktrace
Comment 2 Jesse Glick 2012-01-23 19:58:13 UTC
core-main #319421a20f3c
Comment 3 Jesse Glick 2012-01-24 12:24:54 UTC
*** Bug 207654 has been marked as a duplicate of this bug. ***
Comment 4 Quality Engineering 2012-01-25 16:34:38 UTC
Integrated into 'main-golden', will be available in build *201201250600* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/319421a20f3c
User: Jesse Glick <jglick@netbeans.org>
Log: #207648: AssertionError: memory://fs3//


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo