Bug 207286 - Show Non-printable Characters: consecutive tabs display as one
Show Non-printable Characters: consecutive tabs display as one
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.1
PC Windows Vista
: P3 with 2 votes (vote)
: 7.4
Assigned To: Miloslav Metelka
issues@editor
: PLAN
: 227940 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-13 16:49 UTC by kAlvaro
Modified: 2013-03-27 10:56 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot (2.28 KB, image/png)
2012-01-13 16:49 UTC, kAlvaro
Details
Minimal patch (1.39 KB, patch)
2012-01-13 17:50 UTC, 280Z28
Details | Diff
Patch to fix this issue (262 bytes, patch)
2013-01-25 23:05 UTC, 280Z28
Details | Diff
Patch to fix this issue (1.03 KB, patch)
2013-01-25 23:10 UTC, 280Z28
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kAlvaro 2012-01-13 16:49:57 UTC
Created attachment 114880 [details]
Screenshot

When "Show Non-printable Characters" is enabled, consecutive tabs are represented with a single "»" symbol. I'd expect as many "»" as tabs.

It worked fine in 7.0 so it's a regression.
Comment 1 280Z28 2012-01-13 17:45:37 UTC
Changeset: 5a889930f2f3
Author:    Sam Harwell <sam@tunnelvisionlabs.com>
Date:      2012-01-13 11:42
Message:   Display all tab characters when Show Non-printable Characters is enabled
Issue #207286 - Show Non-printable Characters: consecutive tabs display as one
Comment 2 280Z28 2012-01-13 17:50:54 UTC
Created attachment 114886 [details]
Minimal patch

Well, I took a guess that NetBeans would automatically attach a patch when I selected "finish patch" but it looks like that's not the case. Attached is a minimal patch to correct this issue.
Comment 3 Geertjan Wielenga 2012-01-19 18:13:31 UTC
Added myself and changed the component.
Comment 4 Cheater 2012-07-18 07:47:12 UTC
This issue, is still an issue in 7.2 RC1.

I guess, because I have a compiled version, I cannot apply this patch, or can I?

Is development able to fix this issue in 7.2 Final ?
Comment 5 280Z28 2012-09-22 15:14:38 UTC
I am unable to resolve this issue via a NetBeans plugin. As a user who *always* works with the Show Non-printable Characters option enabled, this patch is essential. It also simplifies the current code and is easy to verify.
Comment 6 280Z28 2013-01-25 23:05:48 UTC
Created attachment 130674 [details]
Patch to fix this issue

The previous patch conflicts with commit 82a545b61c94. I'm attaching an updated patch.
Comment 7 280Z28 2013-01-25 23:10:32 UTC
Created attachment 130675 [details]
Patch to fix this issue

The previous attachment was unintentionally empty
Comment 8 Miloslav Metelka 2013-02-19 14:57:47 UTC
Thanks for the patch. In the end I've chosen to retain multi-char TabView and fix its rendering.
http://hg.netbeans.org/jet-main/rev/c854b1c3d672
Comment 9 Quality Engineering 2013-02-20 05:26:48 UTC
Integrated into 'main-golden', will be available in build *201302192300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c854b1c3d672
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #207286 - Show Non-printable Characters: consecutive tabs display as one.
Comment 10 Jiri Prox 2013-03-26 11:36:33 UTC
*** Bug 227940 has been marked as a duplicate of this bug. ***
Comment 11 kiddiescripterkiller 2013-03-27 10:26:38 UTC
And how do you apply the patch?

I found the file to change the code...

However... 
1)what I have on my machine is way different from what is on the page at: 
http://hg.netbeans.org/main-golden/file/c854b1c3d672/editor.lib2/src/org/netbeans/modules/editor/lib2/view/HighlightsViewUtils.java
My version doesn't import as many files.

And the only way I can open it is in netbeans and it says it is compiled code in the folds.

2)If I try to use the above patch, I can't find it in the code to change it.
And I can't open 2 of the 4 HighlightsViewFactory the $1 and $2 files won't open.


3)If I try to download and run the nightly download exe it won't run...


I'm running on a 64bit windows machine....

And I'm not even close to being a java wizard... I don't even know enough to make myself dangerous...So go easy on me...

Thanks,
Bob
Comment 12 Miloslav Metelka 2013-03-27 10:56:14 UTC
(In reply to comment #11)
> And how do you apply the patch?
Just download a build from http://bits.netbeans.org/dev/nightly/ and use that one. Not sure why it did not run properly.

To see sources and build by yourself you would have to through http://wiki.netbeans.org/DevFaqAccessSourcesUsingMercurial etc.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo