Bug 207165 - Diff between branches
Diff between branches
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Git
7.1
PC Windows Vista
: P3 with 5 votes (vote)
: 7.4
Assigned To: Ondrej Vrabec
issues@versioncontrol
: PLAN
Depends on: 227348
Blocks: 208930
  Show dependency treegraph
 
Reported: 2012-01-11 10:36 UTC by tskorka
Modified: 2013-06-18 11:10 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tskorka 2012-01-11 10:36:01 UTC
Please add a feature which would allow to see a diff between any two GIT branches, or at least current branch and any other selected branch.
Currently I can't find any way to see changes before merging branches.

Related git command is:
git diff BRANCH1..BRANCH2
Comment 1 Ondrej Vrabec 2012-02-28 09:04:18 UTC
*** Bug 208930 has been marked as a duplicate of this bug. ***
Comment 2 markiewb 2013-02-12 09:32:27 UTC
Other usecases:
* git diff origin/master..master (compares local state to upstream state)
* git diff master..FETCH_HEAD (compares local state to state before merging)
Comment 3 Ondrej Vrabec 2013-04-02 14:49:35 UTC
fixed, i guess: core-main #aa6eb01b72d3
Comment 4 Martin Kanak 2013-06-18 11:10:40 UTC
verified 

Product Version: NetBeans IDE Dev (Build 201306162301)
Java: 1.7.0_25; Java HotSpot(TM) Client VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b15
System: Linux version 3.5.0-28-generic running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo