Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 206099 - Incorrect highlight of breakpoints
Incorrect highlight of breakpoints
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.1
PC Mac OS X
: P3 (vote)
: 7.2
Assigned To: Miloslav Metelka
issues@editor
:
: 217897 230921 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 16:22 UTC by Jiri Kovalsky
Modified: 2016-07-07 07:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Only partial highlighting of breakpoint. (17.96 KB, image/png)
2011-12-07 16:22 UTC, Jiri Kovalsky
Details
Incorrect highlighting of a line as breakpoint. (16.92 KB, image/png)
2011-12-07 16:22 UTC, Jiri Kovalsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2011-12-07 16:22:02 UTC
Created attachment 113929 [details]
Only partial highlighting of breakpoint.

Product Version: NetBeans IDE 7.1 (Build 201112062100)
Java: 1.6.0_26; Java HotSpot(TM) 64-Bit Server VM 20.1-b02-384
System: Mac OS X version 10.6.6 running on x86_64; MacRoman; en_US (nb)
User directory: /Users/cesilko/.netbeans/7.1
Cache directory: /Users/cesilko/.netbeans/7.1/var/cache

I don't fully understand the conditions but setting up 1st line breakpoint in some source files doesn't highlight the line correctly - see attached screenshot. Toggling another breakpoint fixes that and shows line background correctly. Removing some breakpoint then does not remove whole background. This can be reproduced in MemoryView project in FixAndContinue.java but it works correctly in MemoryView.java class.
Comment 1 Jiri Kovalsky 2011-12-07 16:22:59 UTC
Created attachment 113930 [details]
Incorrect highlighting of a line as breakpoint.
Comment 2 Miloslav Metelka 2012-06-05 12:05:05 UTC
Reproducible.
Comment 3 Jan Lahoda 2013-07-11 10:30:56 UTC
*** Bug 217897 has been marked as a duplicate of this bug. ***
Comment 4 Jan Lahoda 2013-07-11 10:31:12 UTC
*** Bug 230921 has been marked as a duplicate of this bug. ***
Comment 5 Marian Mirilovic 2013-07-11 11:00:37 UTC
Steps to reproduce:
- add some lines into Java file
- toggle line breakpoint by mouse (click on gutter), use popupmenu or shortcut
- background of the line is changed - but only for part with text, not the rest
(see screenshot - https://netbeans.org/bugzilla/attachment.cgi?id=135501)
- rest of line is repainted once you move out of the line
Comment 6 Martin Balin 2016-07-07 07:30:17 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo