Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 206053 - Make importing of Eclipse Code Formatter possible
Make importing of Eclipse Code Formatter possible
Status: RESOLVED DUPLICATE of bug 197876
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
7.1
PC Windows 7
: P2 with 1 vote (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 09:10 UTC by tomzi
Modified: 2012-07-18 08:15 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomzi 2011-12-07 09:10:21 UTC
In our 250 people company most use Eclipse for development. We also use a shared Code Formatter to mostly ensure that there are no svn differences from pure code formatting. 

However, some also use Netbeans, but there is currently no Netbeans supported way to import code formatting settings that are used by eclipse.

Please provide a way
A) To import formatter settings into Tools/Options/Editor/Formatting
B) Or automatic detection and use of the maven Eclipse Format Plugin
   - http://mvneclipsefmt.sourceforge.net/usage.html
   - http://maven-java-formatter-plugin.googlecode.com/svn/site/0.3.1/usage.html

A) is usable also for ANT projects
B) especially for maven projects

Regards and continue the great work!

Product Version = NetBeans IDE 7.1 RC1 (Build 201112051121)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0
Runtime = Java HotSpot(TM) 64-Bit Server VM 21.0-b17
Comment 1 mdm42 2012-07-18 08:15:48 UTC

*** This bug has been marked as a duplicate of bug 197876 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo