Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 205490 - Source level is set incorrectly for the EJB Module project
Source level is set incorrectly for the EJB Module project
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: EJB Project
7.1
PC Linux
: P2 (vote)
: 7.2
Assigned To: David Konecny
issues@javaee
:
: 206038 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-23 16:53 UTC by vanob
Modified: 2012-04-02 01:15 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vanob 2011-11-23 16:53:51 UTC
[ BUILD # : 201111171527 ]
[ JDK VERSION : 1.7 ]

Ubuntu 11.10 x64
JDK 1.7.0_01 x64

1. Create New Project
 Java EE | EJB Module
2. Click Next
3. Change Java EE Version to  Java EE 5
  Press Finish
4. Go to Project Properties and look Source/Binary Format. It's set to JDK 6.
Comment 1 Martin Fousek 2011-11-24 08:05:37 UTC
I don't think that it should have P1 priority, also P2 looks to me quite high (see similar issue #119052) but it can help us at least to decide if we want to some changes still for NB71.

I took a look into ProjectServerPanel and the source level is highly dependent on the chosen server. AFAIK only the GlassFish 3.1.1 is the only one which supports JDK 7, but JDK 6 is supported by it as well, see:
http://glassfish.java.net/downloads/3.1.1-final.html

So conclusion... Reporter, please could you let us know exactly which app. server do you use? Thanks...  

Probably we should start to handle JDK 7 source level and start with that for GF3.1.1. In any case, I'm proposing to not change that behaviour for NB71 since we are highly probably still compatible with all supported application servers (and current state passed all QE testing). David, Petr - any objections?
Comment 2 vanob 2011-11-24 10:25:35 UTC
I'm using Glassfish 3.1.1
Comment 3 David Konecny 2011-11-24 23:42:57 UTC
I will look into this issue. I do not think it is a showstopper for 7.1. I would be tempted to drop it even to P3 - the problem likely exists in 7.0.
Comment 4 Martin Fousek 2011-11-25 06:45:21 UTC
Totally agree. Ok, thanks.
Comment 5 Petr Jiricka 2011-11-30 14:26:45 UTC
Why the NO71 keyword? That seems incorrect - this problem applies to 7.1, no?
Comment 6 Martin Fousek 2011-12-07 11:46:41 UTC
*** Bug 206038 has been marked as a duplicate of this bug. ***
Comment 7 David Konecny 2012-04-02 01:15:10 UTC
I cannot reproduce this anymore. Likely got fixed while implementing issue 204941.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo