Bug 205220 - "Mid-air collision" when marking issues as fixed
"Mid-air collision" when marking issues as fixed
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Bugzilla
7.1
PC Linux
: P3 with 1 vote (vote)
: 7.2
Assigned To: Tomas Stupka
issues@connecteddeveloper
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-16 18:06 UTC by Jesse Glick
Modified: 2012-04-20 10:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Log file (163.62 KB, text/x-log)
2011-11-16 20:56 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-11-16 18:06:21 UTC
20111116-b4494087e0bb. Starting today; not sure if regression in the IDE, or caused by recent BZ upgrade.

When I commit in Mercurial and ask to Update Issue (Resolve as FIXED, Add details..., After Commit), picking an issue number via Search... (or an already open issue in the pulldown), the commit proceeds but then the issue is opened with an error dialog saying there was a mid-air collision - even though nothing actually happened in BZ during this time. The issue is not edited by the IDE - I need to do it manually.

I use -J-Dnetbeans.vcshook.bugzilla.target_milestone=7.1 (bug #183682), in case it matters.
Comment 1 Jesse Glick 2011-11-16 18:12:11 UTC
Possibly related to bug #205123?
Comment 2 Tomas Stupka 2011-11-16 20:17:14 UTC
bug #205123 was caused by wrong configuration data returned from the bugzilla server - doesn't look like that could be related to the reported mid air problem, though it might be also caused by the recent server update as well. 

tried to reproduce a couple of times - with old configuration file, or a fresh one, but without succes. Just in case - you could try if it will have any effect to refresh your configuration data via the "Reload Attributes" button in the issue, or query view. 

Also not aware about any changes in the bugzilla module which could be responsible for a regression. You have been using the feature recently, prior to the bugzilla update, right?

sound more like issue #182511

please run netbeans with 
-J-Dorg.netbeans.modules.bugtracking.ui.issue.cache.IssueCache.level=-1  
-J-Dorg.netbeans.modules.btracking.vcshooks.level=-1 
-J-Dorg.netbeans.modules.bugzilla.Bugzilla.level=-1
and attach your messages.log file after reproducing the issue
Comment 3 Jesse Glick 2011-11-16 20:33:16 UTC
I tried "Refresh Issue" but not "Reload Attributes" - what is the difference?

Yes I have been using the feature recently, more or less daily.

Does not sound like bug #182511 since in my case I am only trying to make a single change. Often the commit is the first time the IDE has even seen this issue.

I will turn on those logging flags.
Comment 4 Jesse Glick 2011-11-16 20:56:35 UTC
Created attachment 113277 [details]
Log file
Comment 5 Tomas Stupka 2011-11-16 21:04:32 UTC
(In reply to comment #3)
> I tried "Refresh Issue" but not "Reload Attributes" - what is the difference?
refresh issue refreshes the issue
reload attributes used to force a repository configuration refresh which is cached between ide sessions - products, components, milestones, ... . That's what the trouble were in bug #205123
Comment 6 Jesse Glick 2011-11-16 21:54:51 UTC
Tried Reload Attributes (after opening issue but before committing fix). This seems to have worked. So if that is really the solution, perhaps the BZ module should try reloading attributes automatically when it gets this kind of error?
Comment 7 hades200082 2011-12-11 03:10:02 UTC
I have this same issue... I cannot mark any issue as resolved in bugzilla using the netbeans interface either by viewing the issue directly and updating it or by updating during a commit.

FINER [org.netbeans.modules.bugzilla.Bugzilla]: setting value [RESOLVED] on field [task.common.status]
FINER [org.netbeans.modules.bugzilla.Bugzilla]: setting value [FIXED] on field [task.common.resolution]
FINER [org.netbeans.modules.bugzilla.Bugzilla]: setting value [] on field [cc]
FINER [org.netbeans.modules.bugzilla.Bugzilla]: setting value [] on field [removecc]
FINER [org.netbeans.modules.bugzilla.Bugzilla]: setting value [] on field [newcc]
FINER [org.netbeans.modules.bugzilla.Bugzilla]: adding comment [Fixed] to issue #1
FINE [org.netbeans.modules.bugtracking.ui.issue.cache.IssueCache]: returning seen true for issue 1
FINEST [org.netbeans.modules.bugzilla.Bugzilla]: BugzillaAutoupdate.checkAndNotify start
FINEST [org.netbeans.modules.bugzilla.Bugzilla]: BugzillaAutoupdate.checkAndNotify finish
FINE [org.netbeans.modules.bugzilla.Bugzilla]: execute SubmitCommand [issue #1,repository=http://issues.rpr.wildkatz.org]
FINE [org.netbeans.modules.bugzilla.Bugzilla]
org.eclipse.core.runtime.CoreException
	at org.eclipse.mylyn.internal.bugzilla.core.BugzillaClient.parseHtmlError(BugzillaClient.java:1599)
	at org.eclipse.mylyn.internal.bugzilla.core.BugzillaClient.postTaskData(BugzillaClient.java:1071)
	at org.eclipse.mylyn.internal.bugzilla.core.BugzillaTaskDataHandler.postTaskData(BugzillaTaskDataHandler.java:372)
	at org.netbeans.modules.bugzilla.commands.SubmitCommand.execute(SubmitCommand.java:75)
[catch] at org.netbeans.modules.bugzilla.commands.BugzillaExecutor.execute(BugzillaExecutor.java:114)
	at org.netbeans.modules.bugzilla.commands.BugzillaExecutor.execute(BugzillaExecutor.java:98)
	at org.netbeans.modules.bugzilla.commands.BugzillaExecutor.execute(BugzillaExecutor.java:94)
	at org.netbeans.modules.bugzilla.commands.BugzillaExecutor.execute(BugzillaExecutor.java:90)
	at org.netbeans.modules.bugzilla.issue.BugzillaIssue.submitAndRefresh(BugzillaIssue.java:902)
	at org.netbeans.modules.bugzilla.issue.IssuePanel$13.run(IssuePanel.java:2172)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1424)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1968)
FINER [org.netbeans.modules.bugzilla.Bugzilla]: returned error message [mid-air collision occurred while submitting to http://issues.rpr.wildkatz.org. synchronize task and re-submit changes.]
FINE [org.netbeans.modules.bugzilla.Bugzilla]: refreshing issue #1
FINEST [org.netbeans.modules.bugzilla.Bugzilla]: BugzillaAutoupdate.checkAndNotify start
FINEST [org.netbeans.modules.bugzilla.Bugzilla]: BugzillaAutoupdate.checkAndNotify finish
FINE [org.netbeans.modules.bugzilla.Bugzilla]: execute GetTaskDataCommand [repository=http://issues.rpr.wildkatz.org,id=1]
FINE [org.netbeans.modules.bugtracking.ui.issue.cache.IssueCache]: setting task data for issue 1 
FINE [org.netbeans.modules.bugtracking.ui.issue.cache.IssueCache]:  issue 1 was seen
FINE [org.netbeans.modules.bugzilla.Bugzilla]: execute GetConfigurationCommand [repository=http://issues.rpr.wildkatz.org]
FINE [org.netbeans.modules.bugzilla.Bugzilla]:  Refresh bugzilla configuration [http://issues.rpr.wildkatz.org, forceRefresh=false]
FINE [org.netbeans.modules.bugtracking.ui.issue.cache.IssueCache]:  issue 1 isnt changed
Comment 8 Tomas Stupka 2012-04-18 17:51:33 UTC
fixed in core-main #74e6e17d1f4b
Comment 9 Quality Engineering 2012-04-20 10:13:05 UTC
Integrated into 'main-golden', will be available in build *201204200400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/74e6e17d1f4b
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #205220 - "Mid-air collision" when marking issues as fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo