Bug 205007 - Exceptions when module has no declared OpenIDE-Module-Localizing-Bundle
Exceptions when module has no declared OpenIDE-Module-Localizing-Bundle
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Templates
7.1
PC Linux
: P4 (vote)
: 7.3
Assigned To: Martin Kozeny
issues@apisupport
:
: 247823 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 17:35 UTC by Jesse Glick
Modified: 2015-02-04 06:04 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-11-11 17:35:27 UTC
Thrown when running file wizards. Ought to either check for null, or use the displayName param to createLayerEntry. At least:

java.lang.NullPointerException
	at org.netbeans.modules.apisupport.project.ui.wizard.updatecenter.DataModel.regenerate(DataModel.java:136)
	at org.netbeans.modules.apisupport.project.ui.wizard.updatecenter.DataModel.refreshCreatedModifiedFiles(DataModel.java:152)
	at org.netbeans.modules.apisupport.project.ui.wizard.updatecenter.UpdateCenterRegistrationPanel.updateData(UpdateCenterRegistrationPanel.java:114)
	at org.netbeans.modules.apisupport.project.ui.wizard.updatecenter.UpdateCenterRegistrationPanel.readFromDataModel(UpdateCenterRegistrationPanel.java:107)
	at org.netbeans.modules.apisupport.project.ui.wizard.common.BasicWizardIterator$PrivateWizardPanel.readSettings(BasicWizardIterator.java:456)
	at org.netbeans.modules.apisupport.project.ui.wizard.common.BasicWizardIterator$PrivateWizardPanel.readSettings(BasicWizardIterator.java:415)

and:

java.lang.NullPointerException
	at org.netbeans.modules.apisupport.project.ui.wizard.librarydescriptor.CreatedModifiedFilesProvider.getPackagePlusBundle(CreatedModifiedFilesProvider.java:110)
	at org.netbeans.modules.apisupport.project.ui.wizard.librarydescriptor.CreatedModifiedFilesProvider.getTokens(CreatedModifiedFilesProvider.java:132)
	at org.netbeans.modules.apisupport.project.ui.wizard.librarydescriptor.CreatedModifiedFilesProvider.addOperations(CreatedModifiedFilesProvider.java:92)
	at org.netbeans.modules.apisupport.project.ui.wizard.librarydescriptor.CreatedModifiedFilesProvider.createInstance(CreatedModifiedFilesProvider.java:85)
	at org.netbeans.modules.apisupport.project.ui.wizard.librarydescriptor.NameAndLocationPanel.getTemporaryDataModel(NameAndLocationPanel.java:112)
	at org.netbeans.modules.apisupport.project.ui.wizard.librarydescriptor.NameAndLocationPanel.access$000(NameAndLocationPanel.java:63)
	at org.netbeans.modules.apisupport.project.ui.wizard.librarydescriptor.NameAndLocationPanel$1.insertUpdate(NameAndLocationPanel.java:78)
	at javax.swing.text.AbstractDocument.fireInsertUpdate(AbstractDocument.java:185)
	at javax.swing.text.AbstractDocument.handleInsertString(AbstractDocument.java:734)
	at javax.swing.text.AbstractDocument.insertString(AbstractDocument.java:693)
	at javax.swing.text.PlainDocument.insertString(PlainDocument.java:114)
	at javax.swing.text.AbstractDocument.replace(AbstractDocument.java:655)
	at javax.swing.text.JTextComponent.setText(JTextComponent.java:1693)
	at org.netbeans.modules.apisupport.project.ui.wizard.librarydescriptor.NameAndLocationPanel.readFromDataModel(NameAndLocationPanel.java:134)
	at org.netbeans.modules.apisupport.project.ui.wizard.common.BasicWizardIterator$PrivateWizardPanel.readSettings(BasicWizardIterator.java:456)
	at org.netbeans.modules.apisupport.project.ui.wizard.common.BasicWizardIterator$PrivateWizardPanel.readSettings(BasicWizardIterator.java:415)
Comment 2 Quality Engineering 2013-01-08 02:23:37 UTC
Integrated into 'main-golden', will be available in build *201301080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6ba76fd111ef
User: Martin Kozeny <mkozeny@netbeans.org>
Log: #205007: In NB module project at the end of wizard for adding e.g. library descriptor when button Finish is invoked, localizing property bundle is created if not exists and information about library are written there. Displayed name of the module is fetched from manifest file (property OpenIDE-Module-Name).
Comment 3 Quality Engineering 2015-02-04 06:04:03 UTC
*** Bug 247823 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo