Bug 204818 - 4s - ToolbarPool$Folder.createInstance may block in waitFinished()
4s - ToolbarPool$Folder.createInstance may block in waitFinished()
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Actions
7.1
All All
: P1 (vote)
: 7.2
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 208248 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 09:34 UTC by Petr Cyhelsky
Modified: 2012-05-28 07:09 UTC (History)
22 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (100.19 KB, application/nps)
2011-11-08 09:34 UTC, Petr Cyhelsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2011-11-08 09:34:53 UTC
Build: NetBeans IDE Dev (Build 201111070600)
VM: Java HotSpot(TM) Client VM, 21.0-b18, Java(TM) SE Runtime Environment, 1.7.0-b148
OS: Windows 7

User Comments:
nomad3263: Starting Netbeans

jungmat: during Netbeans restart process after struts plugin update

GUEST: ???NB?



Maximum slowness yet reported was 6830 ms, average is 4775
Comment 1 Petr Cyhelsky 2011-11-08 09:34:59 UTC
Created attachment 112987 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2011-11-14 08:00:34 UTC
ToolbarPool$Folder.createInstance may block in waitFinished() - it would be better to wait outside of EDT for all background tasks to finish and only then acquire AWT.
Comment 3 Marian Mirilovic 2012-05-11 14:49:41 UTC
50 reports ... P1
Comment 4 Jaroslav Tulach 2012-05-24 08:27:59 UTC
I tried something in ergonomics#58b182277597 - we'll see how big effect that is going to have.
Comment 5 Jaroslav Tulach 2012-05-28 07:09:09 UTC
*** Bug 208248 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo