Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 204210 - [71cat] [71cat] IllegalArgumentException: Comparison method violates its general contract!
[71cat] [71cat] IllegalArgumentException: Comparison method violates its gene...
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Properties
7.0
All All
: P3 (vote)
: TBD
Assigned To: Jan Peska
issues@utilities
EXCEPTIONS_REPORT
:
: 205778 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 13:43 UTC by muellermi
Modified: 2012-04-04 10:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.06 KB, text/plain)
2011-10-25 13:43 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-10-25 13:43:32 UTC
Build: NetBeans IDE Dev (Build 201110240600)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows XP

User Comments:
muellermi: adding new property to message bundle




Stacktrace: 
java.lang.IllegalArgumentException: Comparison method violates its general contract!
   at java.util.TimSort.mergeHi(TimSort.java:868)
   at java.util.TimSort.mergeAt(TimSort.java:485)
   at java.util.TimSort.mergeForceCollapse(TimSort.java:426)
   at java.util.TimSort.sort(TimSort.java:223)
   at java.util.TimSort.sort(TimSort.java:173)
   at java.util.Arrays.sort(Arrays.java:659)
Comment 1 muellermi 2011-10-25 13:43:37 UTC
Created attachment 112406 [details]
stacktrace
Comment 2 Jan Peska 2011-11-02 14:06:15 UTC
Hi, do you have any idea how to reproduce it?
Comment 3 Marian Mirilovic 2011-12-01 15:04:39 UTC
*** Bug 205778 has been marked as a duplicate of this bug. ***
Comment 4 Jan Peska 2012-04-02 13:18:27 UTC
fix: http://hg.netbeans.org/core-main/rev/e71f6a0cb8cb
Comment 5 Quality Engineering 2012-04-04 10:08:24 UTC
Integrated into 'main-golden', will be available in build *201204040400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e71f6a0cb8cb
User: Jan Peska <JPESKA@netbeans.org>
Log: Issue #204210 - [71cat] [71cat] IllegalArgumentException: Comparison method violates its general contract!
Sort keyList within a synchronized block - editing the collection which is in sorting process throws exception in java 1.7


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo