Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 203826 - Paste not refreshed according to context
Paste not refreshed according to context
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
7.1
PC Windows XP
: P1 (vote)
: 7.1
Assigned To: Jaroslav Tulach
issues@platform
: REGRESSION, TEST
Depends on: 203335
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 13:24 UTC by Jiri Skrivanek
Modified: 2011-11-04 09:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2011-10-17 13:24:26 UTC
Paste refactoring menu is not properly refreshed for the first time but only when context menu is called second time on the node of same type. It is high priority because it blocks commit validation tests and it is a regression. To reproduce:

- create java project
- create a new package
- right-click JavaApplication1.java node and choose Copy
- right-click newpackage. There is "Paste" instead of "Paste|Refactor Copy..., Copy"
- right-click newpackage again. It is OK now.
- right-click JavaApplication1.java node. There is "Paste|Refactor Copy..., Copy" item enabled but it should not be.
- right-click JavaApplication1.java node again. It is OK - Paste is disabled. 

Product Version: NetBeans IDE Dev (Build 201110160600)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)
Comment 1 Jan Becicka 2011-10-17 17:16:11 UTC
I doubt, that this is refactoring issue.
Since when those test failing?
Comment 2 Jiri Skrivanek 2011-10-18 08:52:28 UTC
In build 201110120600 it works, in build 201110160600 it fails. I can't specify better because there were additional failures which hid these ones.
Comment 3 Jan Becicka 2011-10-18 09:33:18 UTC
well, it is not "Paste|Refactor Copy..." which is missing. It is regular Paste which is missing.
If you do Paste -> Refactoring version is called. It means that regular paste type is missing.
Comment 4 Jaroslav Tulach 2011-10-20 05:46:59 UTC
Works for me fine on my Linux, but yes, I've changed the paste action in explorer to update asynchronously to address bug 203335.

If this is a windows only issue then it may be related to bug 88161 which we were trying to fix for 7.1. Try to run with -J-Dnetbeans.slow.system.clipboard.hack=false and see if that helps.
Comment 5 Jiri Skrivanek 2011-10-20 07:20:22 UTC
No, using -J-Dnetbeans.slow.system.clipboard.hack=false doesn't help.
Comment 6 Jiri Skrivanek 2011-10-20 07:48:52 UTC
And it is reproducible also on Linux.
Comment 7 Jaroslav Tulach 2011-11-01 14:53:54 UTC
ergonomics#ec973f889784
Comment 8 Quality Engineering 2011-11-03 15:32:26 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/ec973f889784
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #203826: Don't fire flavor events under a lock. May help the state of paste action as well.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo