Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 203555 - AssertionError: FileName: D:\Documents and Settings\501923470\workspace\dotmed\obj\devclasses\dotmeddataprocessing\test\com\ge\med\dotmed\dataprocessing#f3d169eb@1691a31 dataprocessing at org.netbean
AssertionError: FileName: D:\Documents and Settings\501923470\workspace\dotme...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.1
All All
: P3 (vote)
: 7.1
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
: 201209 202414 203464 204354 204468 213799 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-11 22:30 UTC by minoleg
Modified: 2012-06-11 14:08 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.96 KB, text/plain)
2011-10-11 22:30 UTC, minoleg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description minoleg 2011-10-11 22:30:18 UTC
Build: NetBeans IDE 7.1 Beta (Build 201109252201)
VM: Java HotSpot(TM) Client VM, 20.2-b06, Java(TM) SE Runtime Environment, 1.6.0_27-b07
OS: Windows XP

Stacktrace: 
java.lang.AssertionError: FileName: D:\Documents and Settings\501923470\workspace\dotmed\obj\devclasses\dotmeddataprocessing\test\com\ge\med\dotmed\dataprocessing#f3d169eb@1691a31
dataprocessing
	at org.netbeans.modules.masterfs.filebasedfs.naming.FileName.<init>(FileName.java:73)
	at org.netbeans.modules.masterfs.filebasedfs.naming.NamingFactory.createFileNaming(NamingFactory.java:283)
	at org.netbeans.modules.masterfs.filebasedfs.naming.NamingFactory.registerInstanceOfFileNaming(NamingFactory.java:214)
	at org.netbeans.modules.masterfs.filebasedfs.naming.NamingFactory.fromFile(NamingFactory.java:92)
	at org.netbeans.modules.masterfs.filebasedfs.children.ChildrenSupport$1IOJob.run(ChildrenSupport.java:230)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.refreshImpl(FolderObj.java:444)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.refresh(BaseFileObj.java:796)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.refresh(FolderObj.java:539)
	at org.ope
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.computeChildren(FolderObj.java:196)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.noFolderListeners(FolderObj.java:138)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.removeFileChangeListener(BaseFileObj.java:507)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectKeeper.listenTo(FileObjectKeeper.java:177)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectKeeper.fileDeleted(FileObjectKeeper.java:302)
   at org.openide.filesystems.FCLSupport$DispatchEventWrapper.dispatchEventImpl(FCLSupport.java:148)
Comment 1 minoleg 2011-10-11 22:30:22 UTC
Created attachment 111894 [details]
stacktrace
Comment 2 Jaroslav Tulach 2011-10-12 13:00:10 UTC
ergonomics#9ce4b55d8f3d
Comment 3 Jaroslav Tulach 2011-10-12 13:01:28 UTC
*** Bug 201209 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2011-10-12 13:03:11 UTC
*** Bug 203464 has been marked as a duplicate of this bug. ***
Comment 5 Quality Engineering 2011-10-15 14:48:16 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/58a2fdacaead
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #203555: More logging, but in general it looks like there is a change in isDirectory value which triggers cleanup of previous reference
Comment 6 Jaroslav Tulach 2011-11-04 12:40:31 UTC
*** Bug 202414 has been marked as a duplicate of this bug. ***
Comment 7 Jaroslav Tulach 2011-11-07 13:02:09 UTC
*** Bug 204354 has been marked as a duplicate of this bug. ***
Comment 8 Jaroslav Tulach 2011-11-07 13:04:29 UTC
*** Bug 204468 has been marked as a duplicate of this bug. ***
Comment 9 Jaroslav Tulach 2012-06-11 14:08:40 UTC
*** Bug 213799 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo