Bug 203427 - [71cat] IndexOutOfBoundsException: Invalid line index=600 >= lineCount=1
[71cat] IndexOutOfBoundsException: Invalid line index=600 >= lineCount=1
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Debugger
7.0
All All
: P3 (vote)
: 7.2
Assigned To: Ondrej Brejla
issues@php
EXCEPTIONS_REPORT
:
: 214443 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-10 11:30 UTC by Exceptions Reporter
Modified: 2012-06-20 15:57 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.43 KB, text/plain)
2011-10-10 11:30 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2011-10-10 11:30:21 UTC
This issue was reported manually by mkristofic.
It already has 9 duplicates 


Build: NetBeans IDE 7.0.1 (Build 201107282000)
VM: OpenJDK 64-Bit Server VM, 20.0-b11, OpenJDK Runtime Environment, 1.6.0_22-b22
OS: Linux

User Comments:
schkovich: Commiting to the svn repository

iletras: I asked NB to commit a large (for me) number of changes to my local Subversion store.
While it was committing, the red error icon appeared on the bottom of the NB ui.

geza83: I have no idea.

tprochazka: After modify file outside of Netbenas




Stacktrace: 
java.lang.IndexOutOfBoundsException: Invalid line index=600 >= lineCount=1
   at org.netbeans.editor.LineRootElement.getElement(LineRootElement.java:115)
   at org.openide.text.NbDocument$DocumentRenderer.run(NbDocument.java:691)
   at org.netbeans.editor.BaseDocument.render(BaseDocument.java:1422)
   at org.openide.text.NbDocument$DocumentRenderer.renderToInt(NbDocument.java:666)
   at org.openide.text.NbDocument.findLineOffset(NbDocument.java:187)
   at org.netbeans.modules.php.dbgp.annotations.BrkpntAnnotation.getAnnotationType(BrkpntAnnotation.java:93)
Comment 1 Exceptions Reporter 2011-10-10 11:30:26 UTC
Created attachment 111768 [details]
stacktrace
Comment 2 Milutin Kristofic 2011-10-10 12:29:05 UTC
I am closing bug https://netbeans.org/bugzilla/show_bug.cgi?id=155880 and I took current reports and reassign it to particular components. It's usually problem with not locking line information.
Comment 3 Ondrej Brejla 2012-04-04 09:55:17 UTC
Fixed in web-main #5dd8180ff333
Comment 4 Quality Engineering 2012-04-05 09:40:35 UTC
Integrated into 'main-golden', will be available in build *201204050400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5dd8180ff333
User: Ondrej Brejla <obrejla@netbeans.org>
Log: #203427 - [71cat] IndexOutOfBoundsException: Invalid line index=600 >= lineCount=1
Comment 5 Milutin Kristofic 2012-06-20 15:57:57 UTC
*** Bug 214443 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo