Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 203413 - Installing of jdk7u1-nb-7_0_1 bundle causes system restart on Windows XP
Installing of jdk7u1-nb-7_0_1 bundle causes system restart on Windows XP
Status: VERIFIED FIXED
Product: installer
Classification: Unclassified
Component: JDK bundle
7.0.1
PC Windows XP
: P1 (vote)
: 7.0.1
Assigned To: Yulia Novozhilova
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-10 07:55 UTC by Vladimir Riha
Modified: 2011-11-08 18:05 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
jdk install log (125.61 KB, text/plain)
2011-10-10 07:55 UTC, Vladimir Riha
Details
NetBeans install log (2.19 MB, text/plain)
2011-10-10 07:56 UTC, Vladimir Riha
Details
Installation logs. (75.73 KB, application/x-sdlc)
2011-10-10 12:47 UTC, Jiri Skrivanek
Details
install logs from after restart (41.06 KB, application/x-zip-compressed)
2011-10-10 13:13 UTC, Vladimir Riha
Details
log from silent installer (125.96 KB, text/x-log)
2011-10-10 14:48 UTC, Vladimir Riha
Details
log with norestart parameter (126.03 KB, application/octet-stream)
2011-10-11 09:14 UTC, Vladimir Riha
Details
jre installation log (44.25 KB, text/x-log)
2011-10-14 11:40 UTC, Yulia Novozhilova
Details
Fix - JRE's exit code is caught and the need to restart indicated to the user in the installer UI (113.89 KB, image/png)
2011-11-08 17:37 UTC, Antonin Nebuzelsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-10-10 07:55:15 UTC
Created attachment 111754 [details]
jdk install log

During the installation of this bundle, only JDK seems to be properly installed and after that the system is restarted so NetBeans aren't installed. It doesn't seem to be reproducible on the same system, it happens only during the first installation.
Comment 1 Vladimir Riha 2011-10-10 07:56:42 UTC
Created attachment 111755 [details]
NetBeans install log
Comment 2 Antonin Nebuzelsky 2011-10-10 08:48:12 UTC
Cannot reproduce. Both JDK 7u1 and NetBeans 7.0.1 installed correctly on my XP in vbox. And no automatic restart happening.
Comment 3 Yulia Novozhilova 2011-10-10 09:04:13 UTC
According to the log you attached, both JDK and NetBeans were completely installed and installer finished his work normally. 

Can't reproduce the problem on my Win XP x64 as well. Closing as worksforme. Please feel free to reopen if you are able to reproduce the issue.
Comment 4 Marian Mirilovic 2011-10-10 11:59:42 UTC
Happened at least twice to two engs on two different machines ... Any additional logging ?
Comment 5 Yulia Novozhilova 2011-10-10 12:29:10 UTC
Well, I need more info to understand what is happening. Could someone please answer the following questions:

1) At what moment restart happened? Did installer finish its work before restart or just hung?  Any messages before restart? 
2) What about NetBeans installation folder? Does it exist after restart? 
3) Please take a look at the java installation folder. Is jdk installer "exe" file there? 
4) In case if installation of NetBeans wasn't completed, no info should be logged actually. Please attach all the logs (NB and jdk) you have that corresponds those failed installations (please check the time of the log creation). 

It would be nice to find clean WinXP system and run jdk7u1 installer silently there to see if jdk installer causes the restart of the system. Marian, is that possible?
Comment 6 Jiri Skrivanek 2011-10-10 12:47:51 UTC
Created attachment 111776 [details]
Installation logs.

Attaching my log files. NetBeans installation log file seems to be truncated.
Comment 7 Yulia Novozhilova 2011-10-10 13:08:22 UTC
Thanks! 
Please try to run jdk bundle installer again and try to install NetBeans only (since jdk7u1 is already installed) then attach the log here.
Also, please, check if the Logitech QuickCam service (lvprcsrv.exe) is running.
Comment 8 Vladimir Riha 2011-10-10 13:13:18 UTC
Created attachment 111782 [details]
install logs from after restart

I reproduced it (with NB build) on fresh new WinXP, here are the logs for it. To answer your questions:

1) In the middle of installation process (first case it was about 20% completed, the second one about 45%), no hung, no message or warning was shown, simply the OS restarted.

2) Yes, there is NetBeans installation folder. It contains 32 subfolders and 152 files, total size of 1.75MB. There are 4 subfolders in "C:\Program Files\NetBeans 7.0.1" : nb, platform, ruby, websvccommon 

3) No, there is no exe installer

4) Logs attached.
Comment 9 Yulia Novozhilova 2011-10-10 13:24:36 UTC
vriha, thank you for the logs.
Please check if lvprcsrv.exe service is running on the machine?
Comment 10 Vladimir Riha 2011-10-10 13:44:17 UTC
No, I can't find it, not in Task Manager or in Services (Control Panel - Administrative tool - Services). And I don't have any Logitech accessories so I have no idea why it is in log.

I tried the other scenarios you asked:
- install NetBeans after the first unsuccessful installation using the same installer => already installed JDK was found and recognized by the installer, NetBeans were installed correctly

- I also used a fresh WinXP again and tried to install JDK7u1 only (using jdk only installer) and without any problem. At the end I was asked if I want to reboot or not. I choosed not and as expected no reboot happened.
Comment 11 Yulia Novozhilova 2011-10-10 13:58:22 UTC
vriha, thanks a lot for your investigation!
This reboot question can be a cause of the problem. Could you please try to run jdk installer silently (use [1]) on the fresh Windows system?

[1] > jdk-7u1-windows-i586.exe /s /v/log logfile.log /qn INSTALLDIR=\"C:\Program Files\Java\jdk1.7.0_01\"
Comment 12 Vladimir Riha 2011-10-10 14:48:43 UTC
Created attachment 111789 [details]
log from silent installer

No problem :)

The silent installer ended up with system reboot, just like the cobundle build did. For a short time dialog with a message was displayed saying something like "The Application fail to initialize becase sytem is shutting down".

Log attached.
Comment 13 Yulia Novozhilova 2011-10-11 08:32:37 UTC
Thank you! It looks like jdk installer has changed. Could you please run silent installer with "norestart" option and see if that helps.

> jdk-7u1-windows-i586.exe /s /v/log logfile.log /qn /norestart INSTALLDIR=\"C:\Program Files\Java\jdk1.7.0_01\"
Comment 14 Vladimir Riha 2011-10-11 09:14:40 UTC
Created attachment 111830 [details]
log with norestart parameter

It didn't help. System was rebooted again, the result is the same like when I used the command you mentioned in comment #11.

Log attached
Comment 15 Antonin Nebuzelsky 2011-10-13 15:58:07 UTC
Yulia, what is the outcome of the evaluation?
Comment 16 Yulia Novozhilova 2011-10-13 20:25:05 UTC
I'm waiting for a jdk installer team respond.
Comment 17 Yulia Novozhilova 2011-10-14 11:38:53 UTC
The bug is only reproducible on the systems with jre7 pre-installed on
condition that some jre7 files are held in use by some process (tomcat7.exe in
this case). 
jdk installer bug is filed #7100937
Comment 18 Yulia Novozhilova 2011-10-14 11:40:13 UTC
Created attachment 112048 [details]
jre installation log
Comment 19 Yulia Novozhilova 2011-10-17 15:21:38 UTC
Current state of the fix:
1) jre-7u1-windows-i585.exe installer is now also bundled. It is run first in silent mode with "/norestart" option. It allows to avoid restart but increase the size of the bundle on 18Mb. Exit code is ignored.
2) Then jdk installer is run as usual.

TODO:
1) process jre installer exit code to be able to let user know that restart is required after installation (and install NetBeans as usual). Currently exit code for this case is 3010 (need to be confirmed by jdk installer team).

2) make sure jdk installer is fixed for 7u2 to be able to run only jdk*.exe with "/norestart" option and get proper exit code. (http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7100937)
Comment 20 Antonin Nebuzelsky 2011-11-08 17:37:15 UTC
Created attachment 113012 [details]
Fix - JRE's exit code is caught and the need to restart indicated to the user in the installer UI

A fix for TODO#1 is in place. The bundle for 7u1 behaves as expected now - the unwanted automatic restart in the mid of installation does not happen (JRE installer only returns the different exit code) and the JRE's exit code is processed by the bundle installer to show a warning about the needed restart to the user.
Comment 21 Vladimir Riha 2011-11-08 18:05:13 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo