Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202806 - [71cat] breakpoint moves
[71cat] breakpoint moves
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Java
7.1
PC Windows XP
: P3 (vote)
: 7.2
Assigned To: Martin Entlicher
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 08:29 UTC by muellermi
Modified: 2012-06-13 08:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-09-29 08:29:48 UTC
Product Version = NetBeans IDE Dev (Build 201109260601)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0
Runtime = Java HotSpot(TM) Client VM 21.0-b17

sometimes, and I haven't figured out how to reproduce, if you edit (add/remove lines), set a breakpoint (without storing at this time) and start the app, the breakpoint moves up or down some lines. Often this leads to a non-applicable breakpoint.
Comment 1 Milutin Kristofic 2011-10-04 09:20:37 UTC
Changing a category to debugger -> Martin, do you have any more concrete issue similar to this one?
Comment 2 muellermi 2011-10-06 07:48:20 UTC
Today, I could reproduce this problem:

I have a very samll class for testing purrpose:

[imports]
@ApplicationScoped
public class ParamManager {

    private FacesContext _context;

    @PostConstruct
    private void init() {
        _context = FacesContext.getCurrentInstance();  //#### breakpoint here####
    }

    public String getParam(String param) {
        return _context.getExternalContext().getInitParameter("upload.root");//#### breakpoint here####
    }
}

start debugging - everything is ok
next add @Named Annotation. This annotation requires an additional import.
start debugging, at least one breakpoint moves

delete or add some lines _before_ the class: same problem

comclusion: breakpoint move happens when the linecount before the class is changed
Comment 3 Martin Entlicher 2011-10-06 17:13:52 UTC
Thanks for the description.
Comment 4 Martin Entlicher 2012-06-13 08:55:52 UTC
It looks like this was fixed by http://hg.netbeans.org/main-golden/rev/bab19f4f36e5
It behaves fine for me in recent dev builds.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo