Bug 202712 - enabled bugzilla tagging disables update issue with Bugzilla version 4.02
enabled bugzilla tagging disables update issue with Bugzilla version 4.02
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Bugzilla
7.1
PC Windows 7
: P2 (vote)
: TBD
Assigned To: Tomas Stupka
issues@connecteddeveloper
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-27 07:41 UTC by rgarske
Modified: 2013-08-28 10:23 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments
Screen shot of error popup dialog. (20.14 KB, image/jpeg)
2011-09-27 07:41 UTC, rgarske
Details
messages.log of session where bug occured. (74.30 KB, application/octet-stream)
2011-09-27 07:43 UTC, rgarske
Details
messages.log with switch -J-Dorg.netbeans.modules.bugzilla.Bugzilla.level=-1 (82.04 KB, application/octet-stream)
2011-09-27 15:08 UTC, rgarske
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rgarske 2011-09-27 07:41:21 UTC
Created attachment 111220 [details]
Screen shot of error popup dialog.

I have a local Bugzilla installation on a Webserver under my control.
The Issue-Tracker DEA_BUGS connects to a Bugzilla 4.02 instance on Host "by-lex1",
which is an alias, the real server name is "bydea01100". The server is running on Windows Server 2003 and the webserver used for bugzilla is IIS.

Netbeans can connect to the bugzilla instance and read the issues, but it can not update them. When I try to update an issue with mercurial commit action, I get an error popup, see attachment 1 [details].

I will attach my messages.log as attachment 2 [details] after filing this bug.
Comment 1 rgarske 2011-09-27 07:43:38 UTC
Created attachment 111221 [details]
messages.log of session where bug occured.
Comment 2 Tomas Stupka 2011-09-27 14:53:36 UTC
please run netbeans with the switch -J-Dorg.netbeans.modules.bugzilla.Bugzilla.level=-1, reproduce the problem and attach the messages.log file to this issue

thanks
Comment 3 rgarske 2011-09-27 15:08:05 UTC
Created attachment 111243 [details]
messages.log with switch -J-Dorg.netbeans.modules.bugzilla.Bugzilla.level=-1

I addes the switch to the netbeans.conf file, started netbeans, used "Find Issues" to search for the issue and then tried to add a comment and then submit it. This produces the same kind of error, no need to really change my project again and commit it.
Comment 4 Tomas Stupka 2011-09-27 17:19:46 UTC
looks like this is caused by the mylyn connector library we use - see https://bugs.eclipse.org/bugs/show_bug.cgi?id=346882 for more info

see https://bugs.eclipse.org/bugs/show_bug.cgi?id=346882#c15 for a possible workaround
Comment 5 rgarske 2011-09-28 06:55:09 UTC
(In reply to comment #4)
> looks like this is caused by the mylyn connector library we use - see
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=346882 for more info
> see https://bugs.eclipse.org/bugs/show_bug.cgi?id=346882#c15 for a possible
> workaround

Yes, this workaround fixes it for now. I have not used the tagging anyway, althow it was enabled.  Is there any chance to get this fixed, or is the mylin Connector library third party and you don't have the source? At least this would explain the eclipse namespace I see in my messages.log.
Comment 6 Tomas Stupka 2011-09-30 08:44:48 UTC
(In reply to comment #5)
> Is there any chance to get this fixed, or is the mylin
> Connector library third party and you don't have the source? 
the library is third party, so we have to wait and upgrade after it is fixed on their side.
no defect to fix in netbeans, changing to task
Comment 7 Tomas Stupka 2013-08-28 10:23:05 UTC
https://bugs.eclipse.org/bugs/show_bug.cgi?id=346882 is fixed 
and the relevant mylyn libs are shipped with NB for some time now, so closing this one as well


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo