Bug 202418 - Run process not finished when targeting cluster
Run process not finished when targeting cluster
Status: VERIFIED WORKSFORME
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.1
PC Windows XP
: P3 (vote)
: 7.1
Assigned To: Vince Kraemer
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-21 12:40 UTC by Jiri Skrivanek
Modified: 2012-11-22 12:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2011-09-21 12:40:37 UTC
If you run project with cluster as a target server and then close the IDE, it shows warning that the run process is still running in spite output window shows finished build and there is no progress bar. To reproduce:

- create cluster
cd glassfish3/bin
asadmin start-domain
asadmin create-cluster c1
asadmin create-local-instance --cluster c1 li1c1
asadmin create-local-instance --cluster c1 li2c1
asadmin create-local-instance sli
asadmin start-cluster c1
asadmin start-local-instance sli
- start IDE
- register that GlassFish server in IDE and type c1 in the Target field in
Domain Location page of the Add Server Instance wizard
- create web application
- run this application
- close the IDE. It shows warning that process "WebApplication1 (run)" is not finished.

Product Version: NetBeans IDE Dev (Build 201109190600)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)
Comment 1 Vince Kraemer 2011-09-23 18:07:23 UTC
can replicate
Comment 2 TomasKraus 2012-11-20 15:41:48 UTC
This was already fixed in 7.3 (I remember similar bug). I can't reproduce this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo