Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202397 - Cannot deploy to GlassFish 3.1.1 because domain upgrade is called
Cannot deploy to GlassFish 3.1.1 because domain upgrade is called
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.1
PC Windows XP
: P1 (vote)
: 7.1
Assigned To: Vince Kraemer
issues@serverplugins
:
: 202483 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-21 09:11 UTC by Jiri Skrivanek
Modified: 2011-09-23 07:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Server log from two consequent attempts to run project. (15.26 KB, text/plain)
2011-09-21 09:11 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2011-09-21 09:11:47 UTC
Created attachment 110952 [details]
Server log from two consequent attempts to run project.

When you try to run web project against GlassFish 3.1.1 server it never finishes because server is not started but instead is called domain upgrade. To reproduce:

- install GlassFish 3.1.1
- add instance to IDE
- create web project
- run created project. It doesn't open server log automatically and it si running forever. If you open server log in Services tab, you see that domain upgrade is called but server is not started afterwards (see attached log).

Product Version: NetBeans IDE Dev (Build 201109202329)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)
Comment 1 Jiri Skrivanek 2011-09-22 11:18:44 UTC
*** Bug 202483 has been marked as a duplicate of this bug. ***
Comment 2 muellermi 2011-09-22 12:41:13 UTC
I switched back to Build201109180600. This version is still ok for GlassFish.
Comment 3 Vince Kraemer 2011-09-22 13:13:44 UTC
http://hg.netbeans.org/web-main/rev/7653f1dec7e0
Comment 4 Jiri Skrivanek 2011-09-22 13:56:53 UTC
Works OK in custom trunk build. Please, transplant the patch to the beta branch.
Comment 5 Quality Engineering 2011-09-22 14:51:36 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/7653f1dec7e0
User: vince kraemer <vkraemer@netbeans.org>
Log: #202397 : unnecessary call to upgrade
Comment 6 Vince Kraemer 2011-09-22 18:04:04 UTC
integrated to releases... http://hg.netbeans.org/releases/changeset/e2c91e734559
Comment 7 Jiri Skrivanek 2011-09-23 07:59:58 UTC
Verified in NetBeans IDE 7.1 Beta (Build 201109222201).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo