Bug 202380 - No code completion in FXML files
No code completion in FXML files
Status: RESOLVED DUPLICATE of bug 204741
Product: javafx
Classification: Unclassified
Component: Editor
7.1
Macintosh (x86) Other
: P3 with 1 vote (vote)
: 7.2
Assigned To: David Strupl
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-20 20:44 UTC by John Jullion-ceccarelli
Modified: 2011-11-07 09:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Jullion-ceccarelli 2011-09-20 20:44:55 UTC
Why isn't there code completion in FXML files? Shouldn't this come for free is we reference the DTD or schema?
Comment 1 David Strupl 2011-09-21 13:03:52 UTC
The question is whether we reference DTD or schema (if there actually is one). I will check with Anton and Svata.
Comment 2 David Strupl 2011-10-03 12:23:22 UTC
I will have a look at this.

Seems like not only there is no schema but also that no fixed schema can capture the FXML format. I will try to do something with it.
Comment 3 David Strupl 2011-10-12 12:21:46 UTC
There is now code completion when the source is not broken. Marking the issue as fixed.
Comment 4 ril3y 2011-10-29 21:00:43 UTC
This bug still exists in Netbeans 7.1 with Javafx on OSX.  My source is NOT broken and I still do not  get suggestions.
Comment 5 David Strupl 2011-10-30 07:49:05 UTC
For now the suggestions appear only on specific places (where you can type class name or field name). Improvements in the next release ...
Comment 6 Anton Chechel 2011-11-07 09:35:39 UTC

*** This bug has been marked as a duplicate of bug 204741 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo