Bug 202173 - Cannot install JIRA plugin
Cannot install JIRA plugin
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Autoupdate
7.1
PC Windows XP
: P2 (vote)
: 7.1
Assigned To: Jiri Rechtacek
au-issues
: PLATFORM, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-15 10:31 UTC by Rokko
Modified: 2011-09-19 13:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rokko 2011-09-15 10:31:32 UTC
Product Version = NetBeans IDE Dev (Build nbms-and-javadoc-7899-on-20110914)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0-ea
Runtime = Java HotSpot(TM) Client VM 21.0-b02


1. Install NetBeans IDE Dev (Build nbms-and-javadoc-7899-on-20110914) - all works fine;
2. Find all available updates and install them;
3. Restart the IDE (it's required);
4. Every time you will close the IDE, it will restart automatically.
Comment 1 Jiri Rechtacek 2011-09-15 12:10:16 UTC
  Product Version         = NetBeans IDE Dev (Build nbms-and-javadoc-7899-on-20110914) (#73966831dda1)
  Operating System        = Linux version 2.6.38-11-generic running on i386
  Java; VM; Vendor        = 1.6.0_26; Java HotSpot(TM) Client VM 20.1-b02; Sun Microsystems Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_26-b03
  Java Home               = /usr/local/share/java/jdk1.6.0_26/jre
  System Locale; Encoding = en_US (nb); UTF-8

No updates found, I cannot reproduce it.

Give me more details about your installation, please. Did you download NetBeans-dev-nbms-and-javadoc-7899-on-20110914-minimal.zip(my choice) or NetBeans-dev-nbms-and-javadoc-7899-on-20110914-full.zip? Run your IDE with fresh userdir? If not, are you able to reproduce it again with fresh userdir? Any other steps I missed? Thanks
Comment 2 Jiri Rechtacek 2011-09-16 14:47:02 UTC
Rokko@netbeans.org wrote:
this is the list of all steps I've done:
1. download NetBeans-dev-nbms-and-javadoc-7899-on-20110914 (Platform SDK, JAVA SE & FX) platform independent zip
2. install it using a fresh userdir
3. Step that I  forgot: import settings and plugins from previous installation (7.0)
4. Update all

I've tried several times to reproduce the issue, and I've figured out that there is something wrong in JIRA plugin.
After installing the JIRA plugin via the IDE plugins dialog, at the first restart, a warning message pops up...

...I disable the module and continue..
From now, every time I try to close the IDE, it will restart.
I tried to uninstall the JIRA plugin, but the IDE continues to restart automatically.
I tried to delete all files in .netbeans\dev\update\download, and this as fixed the issue.
Comment 3 Jiri Rechtacek 2011-09-16 15:09:20 UTC
Rocco, could you reproduce your scenario on build from http://bits.netbeans.org/download/trunk/nightly/latest/zip/ instead of http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastSuccessfulBuild/artifact/ ? I can install JIRA in clean dir on build from bits.netbeans.org and cannot on build from deadlock.netbeans.org Thanks
Comment 4 Jiri Rechtacek 2011-09-19 13:45:11 UTC
Rokko@netbeans.org wrote:
Using latest nightly build from bits.netbeans.org, JIRA plugin installation works fine. No auto-restart.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo