Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202130 - [71cat] IllegalStateException: This method must be called in the event thread.
[71cat] IllegalStateException: This method must be called in the event thread.
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Persistence
7.1
All All
: P3 (vote)
: 7.1
Assigned To: Sergey Petrov
issues@javaee
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-14 13:02 UTC by muellermi
Modified: 2011-09-17 14:18 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.58 KB, text/plain)
2011-09-14 13:02 UTC, muellermi
Details
stacktrace (4.84 KB, text/plain)
2011-09-15 08:40 UTC, Martin Fousek
Details
stacktrace (5.58 KB, text/plain)
2011-09-16 11:18 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-09-14 13:02:09 UTC
Build: NetBeans IDE Dev (Build 201109132156)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows XP

User Comments:
muellermi: add persistence unit via context menu




Stacktrace: 
java.lang.IllegalStateException: This method must be called in the event thread.
   at org.netbeans.modules.j2ee.core.api.support.progress.ProgressSupport.invoke(ProgressSupport.java:109)
   at org.netbeans.modules.j2ee.core.api.support.progress.ProgressSupport.invoke(ProgressSupport.java:94)
   at org.netbeans.modules.j2ee.common.DatasourceUIHelper.fetchDataSources(DatasourceUIHelper.java:461)
   at org.netbeans.modules.j2ee.common.DatasourceUIHelper.connect(DatasourceUIHelper.java:473)
   at org.netbeans.modules.j2ee.common.DatasourceUIHelper.connect(DatasourceUIHelper.java:423)
   at org.netbeans.modules.web.project.WebJPADataSourceSupport.connect(WebJPADataSourceSupport.java:72)
Comment 1 muellermi 2011-09-14 13:02:13 UTC
Created attachment 110751 [details]
stacktrace
Comment 2 Martin Fousek 2011-09-15 08:40:28 UTC
Created attachment 110776 [details]
stacktrace

invoke context mennu on package -> create entity class
Comment 3 muellermi 2011-09-16 11:18:00 UTC
Created attachment 110804 [details]
stacktrace

project, right mouse click, add persistence unit
Comment 4 Sergey Petrov 2011-09-16 11:54:21 UTC
may be caused by recent changes in wizards, start failing on 110913, but this one may be fixable, will evaluate
Comment 5 Sergey Petrov 2011-09-16 15:48:05 UTC
http://hg.netbeans.org/web-main/rev/ba2929cdf4e4
handle case if pane; constructor is called out of edt
Comment 6 Quality Engineering 2011-09-17 14:18:30 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/ba2929cdf4e4
User: Sergey B. Petrov <sj-nb@netbeans.org>
Log: #202130 code is called from edt and sometimes outside of edt now, wrap sensitive code in appropriate logic


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo