Bug 201900 - Full screen on OS X Lion
Full screen on OS X Lion
Status: RESOLVED DUPLICATE of bug 215283
Product: platform
Classification: Unclassified
Component: JDK Problems
7.0
Macintosh Mac OS X
: P2 with 10 votes (vote)
: 7.2
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-09 16:39 UTC by claus_ch
Modified: 2013-07-31 14:08 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Attach (195.69 KB, image/png)
2012-03-06 12:03 UTC, ivanwhm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description claus_ch 2011-09-09 16:39:39 UTC
Offer the possibility to run NetBeans full screen on OS X Lion.
Comment 1 Stanislav Aubrecht 2011-09-12 10:43:33 UTC
patch is welcome
Comment 2 Eduardo.m Costa 2011-11-27 16:17:28 UTC
According to this link:

http://itracki.com/dev/mac-tutorials/mac-tutorial-os-lion-app-fullscreen/

It seems we can achieve it by changing how NB is bundled.
Comment 3 ivanwhm 2012-03-06 12:03:26 UTC
Created attachment 116390 [details]
Attach
Comment 4 ivanwhm 2012-03-06 12:04:21 UTC
netbeans error when viewing in full screen mode, more details in the attachment sent.
Comment 5 Stanislav Aubrecht 2012-03-06 12:06:39 UTC
this is fixed already in recent dev builds

the problem with status bar is reported in #209112
Comment 6 scooper4711 2013-01-30 16:18:52 UTC
The ability to go full screen isn't consistently enabled upon startup. The only way to get it to show up is to quit netbeans 7.3 RC1 and restart.
I'm having about 33% failure rate for the icon to go full screen being present.
I marked this as "reopened", not sure if that's the correct workflow or if you'd rather I open a new bug.

I'm running 10.8 Mountain Lion
Comment 7 Stanislav Aubrecht 2013-02-27 15:37:46 UTC
The full screen button is provided by the JDK, NetBeans does not control it.
Comment 8 Stanislav Aubrecht 2013-07-31 14:08:17 UTC
Most likely a duplicate of #215283

*** This bug has been marked as a duplicate of bug 215283 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo