Bug 201726 - Uncompilable Source code
Uncompilable Source code
Status: RESOLVED DUPLICATE of bug 182009
Product: java
Classification: Unclassified
Component: Project
7.0.1
Other Linux
: P2 (vote)
: 7.2
Assigned To: Tomas Zezula
issues@java
: JDK_1.7, PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-07 07:43 UTC by dwuysan
Modified: 2012-01-18 09:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
netbeans log file from when runtime exception happened (70.52 KB, application/octet-stream)
2012-01-17 21:20 UTC, twolf2919
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dwuysan 2011-09-07 07:43:35 UTC
Product Version = NetBeans IDE 7.0.1 (Build 201107282000)
Operating System = Linux version 2.6.38-11-generic running on amd64
Java; VM; Vendor = 1.7.0_02-ea
Runtime = Java HotSpot(TM) 64-Bit Server VM 22.0-b02
Comment 1 pgebauer 2011-09-07 09:38:24 UTC
Is any more info available?
Comment 2 dwuysan 2011-09-08 00:06:52 UTC
The issue occurs when doing a maven build mvn install via Netbeans. This generally happens after doing a number of JUnit test run (Ctrl+Shift+F6).

The compilation failed, and the output shows the error Uncompilable Source Code.

Netbeans 7.0.1 is currently running using 1.7.0_02-ea; Java HotSpot(TM) 64-Bit Server VM 22.0-b02. That being said, the Java Platform on each module is set to jrockit-jdk1.6.0_26-R28.1.4-4.0.1. Source level 1.6.

In order to resolve the issue, have to do mvn clean install.

Some of the article on the internet suggest this issue relates to Compile on Save. At the moment, have set it to 'For test execution only'
Comment 3 Marian Mirilovic 2011-09-08 12:41:55 UTC
Could you share with us the project ?
Comment 4 dwuysan 2011-09-10 00:46:31 UTC
Just another additional information.

Once I change my JDK to 1.6.0_26 for Netbeans, there is no problem anymore.

See http://markmail.org/message/rlpxrslayoeviqkw

The question is that why this is still occurring. Whilst I have configured NETBEANS to run using JDK 1.7, the Compile Java Platform has been set to JDK 1.6.
Comment 5 twolf2919 2012-01-17 21:20:49 UTC
Created attachment 114979 [details]
netbeans log file from when runtime exception happened
Comment 6 twolf2919 2012-01-17 21:22:20 UTC
I can reproduce this problem pretty regularly.  I have several J2SE (with existing source) Netbeans projects, P1, P2, P3.  All projects have "Compile On Save" enabled.

Starting condition: Netbeans is up and running with P1 open.

1) Close P1.
2) Open P2.  "Clean and Build Main Project"
3) Run project

I almost always see the "Uncompilable source code" error (see below for a sample stack trace).  When I do an "rm -rf $HOME/.netbeans/7.1/var/cache/" Everything works from that point on....until I go to another project again.

I saved the "cache/" directory from the last time it happened, in case someone wants to look at it.  I'm also going to attach messages.log (it has various exceptions - don't know if they're related).

Finally, I increased the priority to P2 given that it can happen so frequently and stops one from actually running ones application in the IDE.


run:
17 Jan 2012 16:00:18 - java.util.concurrent.ExecutionException: java.lang.RuntimeException: Uncompilable source code
17 Jan 2012 16:00:18 - 	at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222)
17 Jan 2012 16:00:18 - 	at java.util.concurrent.FutureTask.get(FutureTask.java:83)
17 Jan 2012 16:00:18 - 	at javax.swing.SwingWorker.get(SwingWorker.java:582)
17 Jan 2012 16:00:18 - 	at com.netforensics.ui.login.ComponentConfigTask.done(ComponentConfigTask.java:72)
17 Jan 2012 16:00:18 - 	at javax.swing.SwingWorker$5.run(SwingWorker.java:717)
17 Jan 2012 16:00:18 - 	at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.run(SwingWorker.java:814)
17 Jan 2012 16:00:18 - 	at sun.swing.AccumulativeRunnable.run(AccumulativeRunnable.java:95)
17 Jan 2012 16:00:18 - 	at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.actionPerformed(SwingWorker.java:824)
17 Jan 2012 16:00:18 - 	at javax.swing.Timer.fireActionPerformed(Timer.java:291)
17 Jan 2012 16:00:18 - 	at javax.swing.Timer$DoPostEvent.run(Timer.java:221)
17 Jan 2012 16:00:18 - 	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
17 Jan 2012 16:00:18 - 	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:677)
17 Jan 2012 16:00:18 - 	at java.awt.EventQueue.access$000(EventQueue.java:85)
17 Jan 2012 16:00:18 - 	at java.awt.EventQueue$1.run(EventQueue.java:638)
17 Jan 2012 16:00:18 - 	at java.awt.EventQueue$1.run(EventQueue.java:636)
17 Jan 2012 16:00:18 - 	at java.security.AccessController.doPrivileged(Native Method)
17 Jan 2012 16:00:18 - 	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
17 Jan 2012 16:00:18 - 	at java.awt.EventQueue.dispatchEvent(EventQueue.java:647)
17 Jan 2012 16:00:18 - 	at com.netforensics.ui.NFEventQueue.dispatchEvent(NFEventQueue.java:27)
17 Jan 2012 16:00:18 - 	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
17 Jan 2012 16:00:18 - 	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
17 Jan 2012 16:00:18 - 	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
17 Jan 2012 16:00:18 - 	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
17 Jan 2012 16:00:18 - 	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
17 Jan 2012 16:00:18 - 	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
17 Jan 2012 16:00:18 - Caused by: java.lang.RuntimeException: Uncompilable source code
17 Jan 2012 16:00:18 - 	at com.netforensics.ui.login.ComponentConfigTask.doInBackground(ComponentConfigTask.java)
17 Jan 2012 16:00:18 - 	at javax.swing.SwingWorker$1.call(SwingWorker.java:277)
17 Jan 2012 16:00:18 - 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
17 Jan 2012 16:00:18 - 	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
17 Jan 2012 16:00:18 - 	at javax.swing.SwingWorker.run(SwingWorker.java:316)
17 Jan 2012 16:00:18 - 	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
17 Jan 2012 16:00:18 - 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
17 Jan 2012 16:00:18 - 	at java.lang.Thread.run(Thread.java:680)
BUILD SUCCESSFUL (total time: 1 minute 52 seconds)
Comment 7 twolf2919 2012-01-17 21:24:10 UTC
This is weird - what happened to all the older attachments and older comments on this bug?  Or the 8 votes it used to have?
Comment 8 Tomas Zezula 2012-01-18 09:00:49 UTC

*** This bug has been marked as a duplicate of bug 182009 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo