Bug 201230 - AssertionError: #46802: project being closed which was never opened?? NbModuleProject[/space/src/nb/main/web.struts@4371e7ca:80d4ac]
AssertionError: #46802: project being closed which was never opened?? NbModul...
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
7.0
All All
: P3 (vote)
: 7.1
Assigned To: Jesse Glick
issues@apisupport
EXCEPTIONS_REPORT
: ERGONOMICS
Depends on:
Blocks: 46802
  Show dependency treegraph
 
Reported: 2011-08-23 02:18 UTC by Jesse Glick
Modified: 2011-11-03 15:42 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1000 bytes, text/plain)
2011-08-23 02:19 UTC, Jesse Glick
Details
stacktrace (998 bytes, text/plain)
2011-08-26 09:38 UTC, Petr Cyhelsky
Details
stacktrace (1012 bytes, text/plain)
2011-09-19 22:48 UTC, Michel Graciano
Details
stacktrace (1014 bytes, text/plain)
2011-09-23 19:04 UTC, Jesse Glick
Details
stacktrace (995 bytes, text/plain)
2011-09-27 18:07 UTC, David Konecny
Details
stacktrace (1013 bytes, text/plain)
2011-09-30 12:56 UTC, Michel Graciano
Details
stacktrace (1011 bytes, text/plain)
2011-10-03 12:32 UTC, Antonin Nebuzelsky
Details
stacktrace (1001 bytes, text/plain)
2011-10-03 14:35 UTC, Petr Cyhelsky
Details
stacktrace (996 bytes, text/plain)
2011-10-10 09:50 UTC, Jiri Prox
Details
stacktrace (1006 bytes, text/plain)
2011-10-14 11:47 UTC, Petr Cyhelsky
Details
stacktrace (1001 bytes, text/plain)
2011-10-17 13:05 UTC, Jiri Prox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-08-23 02:18:58 UTC
Build: NetBeans IDE Dev (Build 20110822-e6b705af222a)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
jglick: Deleting a group that had just been opened.




Stacktrace: 
java.lang.AssertionError: #46802: project being closed which was never opened?? NbModuleProject[/space/src/nb/main/web.struts@4371e7ca:80d4ac]
   at org.netbeans.modules.apisupport.project.NbModuleProject$OpenedHook.projectClosed(NbModuleProject.java:714)
   at org.netbeans.spi.project.ui.ProjectOpenedHook$1.projectClosed(ProjectOpenedHook.java:87)
   at org.netbeans.spi.project.ui.support.UILookupMergerSupport$OpenHookImpl.projectClosed(UILookupMergerSupport.java:207)
   at org.netbeans.spi.project.ui.ProjectOpenedHook$1.projectClosed(ProjectOpenedHook.java:87)
   at org.netbeans.modules.project.ui.OpenProjectList.notifyClosed(OpenProjectList.java:1136)
   at org.netbeans.modules.project.ui.OpenProjectList.access$2600(OpenProjectList.java:131)
Comment 1 Jesse Glick 2011-08-23 02:19:02 UTC
Created attachment 110142 [details]
stacktrace
Comment 2 Petr Cyhelsky 2011-08-26 09:38:35 UTC
Created attachment 110235 [details]
stacktrace
Comment 3 Michel Graciano 2011-09-19 22:48:59 UTC
Created attachment 110886 [details]
stacktrace
Comment 4 Michel Graciano 2011-09-20 12:59:36 UTC
I was closing the Form project.
Comment 5 Jesse Glick 2011-09-23 19:04:22 UTC
Created attachment 111111 [details]
stacktrace

Closing an NBM project whose opening had triggered apisupport cluster activation.
Comment 6 David Konecny 2011-09-27 18:07:34 UTC
Created attachment 111255 [details]
stacktrace

I just started a fresh userdir and opened single project (web.jsf from NB repo). After scanning has finished I created a New Project Group and got this exception. I noticed for a moment that my project disappeared from the list of projects.
Comment 7 Michel Graciano 2011-09-30 12:56:43 UTC
Created attachment 111362 [details]
stacktrace
Comment 8 Antonin Nebuzelsky 2011-10-03 12:32:50 UTC
Created attachment 111417 [details]
stacktrace

Had only "junit" module project open. Later I invoked close action. The project closed and the exception got raised.
Comment 9 Petr Cyhelsky 2011-10-03 14:35:50 UTC
Created attachment 111424 [details]
stacktrace
Comment 10 Jiri Prox 2011-10-10 09:50:12 UTC
Created attachment 111760 [details]
stacktrace

AE when closing nb module project
Comment 11 Petr Cyhelsky 2011-10-14 11:47:38 UTC
Created attachment 112049 [details]
stacktrace
Comment 12 Jiri Prox 2011-10-17 13:05:44 UTC
Created attachment 112125 [details]
stacktrace

Closing NB module just after opening it
Comment 13 Jesse Glick 2011-11-01 19:27:08 UTC
Most instances seem to be caused by ergonomics, but I cannot reproduce just by opening an NBM project in an ergonomics-enabled build and then closing it again. Can just suppress the assertion though it is hard to say what deeper problem might remain broken.
Comment 14 Jesse Glick 2011-11-01 19:30:47 UTC
core-main #3e07942771da
Comment 15 Quality Engineering 2011-11-02 15:18:55 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/3e07942771da
User: Jesse Glick <jglick@netbeans.org>
Log: #201230: AssertionError: #46802: project being closed which was never opened?? NbModuleProject[/space/src/nb/main/web.struts@4371e7ca:80d4ac]
Comment 16 Quality Engineering 2011-11-03 15:42:15 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/3e07942771da
User: Jesse Glick <jglick@netbeans.org>
Log: #201230: AssertionError: #46802: project being closed which was never opened?? NbModuleProject[/space/src/nb/main/web.struts@4371e7ca:80d4ac]


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo