Bug 200833 - "Export Package" action needed on Packages in NetBeans modules
"Export Package" action needed on Packages in NetBeans modules
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
7.0
All All
: P2 with 1 vote (vote)
: 7.4
Assigned To: Martin Kozeny
issues@apisupport
http://blogs.oracle.com/geertjan/entr...
: API, PLAN
: 202096 (view as bug list)
Depends on:
Blocks: 185897 228409
  Show dependency treegraph
 
Reported: 2011-08-10 13:08 UTC by Geertjan Wielenga
Modified: 2013-07-17 05:11 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
apisupport ant patch (16.59 KB, patch)
2013-04-10 14:19 UTC, Martin Kozeny
Details | Diff
java api patch (13.01 KB, patch)
2013-04-10 14:19 UTC, Martin Kozeny
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geertjan Wielenga 2011-08-10 13:08:49 UTC
An "Export Package" action needed on Packages in NetBeans modules.
Comment 1 Jesse Glick 2011-08-10 13:10:04 UTC
Requires a new SPI, since the action itself would live in java.project.
Comment 2 Jesse Glick 2011-08-10 17:53:54 UTC
At the same time, it would be good to extend the API & SPI to permit listening for changes. While apisupport.ant normally recreates the logical view in response to any change to project.xml, thus refreshing the badges, maven.apisupport and maven.osgi can only inject an AQI into project lookup (and maven does not refresh the logical view in general when pom.xml has been modified).
Comment 3 Jesse Glick 2011-10-14 17:25:28 UTC
*** Bug 202096 has been marked as a duplicate of this bug. ***
Comment 4 mt.uulu 2012-07-14 02:28:39 UTC
An "Export Package" action needed on Packages in NetBeans modules. +1
Comment 5 Martin Kozeny 2013-04-09 12:07:07 UTC
https://hg.netbeans.org/core-main/rev/9e03f1d2e689
Comment 6 Martin Kozeny 2013-04-10 14:19:11 UTC
Created attachment 133418 [details]
apisupport ant patch
Comment 7 Martin Kozeny 2013-04-10 14:19:40 UTC
Created attachment 133419 [details]
java api patch
Comment 8 Quality Engineering 2013-04-28 02:19:18 UTC
Integrated into 'main-golden', will be available in build *201304272301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/dd88e665a752
User: Martin Kozeny <mkozeny@netbeans.org>
Log: #200833: "Export Package" action is now provided on Packages in NetBeans modules. When selecting set of packages where is at least one not public, then action "Export Package" is enabled, otherwise is enabled action "Unexport Package" (this is the case that all relevant packages in set are exported).
Comment 9 mienamoo 2013-04-29 06:19:30 UTC
Where should this action appear? I am not seeing it in build 201304272301 for Ant or Maven based module projects...
Comment 10 Milos Kleint 2013-04-29 07:21:08 UTC
(In reply to comment #9)
> Where should this action appear? I am not seeing it in build 201304272301 for
> Ant or Maven based module projects...

maven ones are not done yet. (i'm working on it)
Comment 11 mienamoo 2013-04-29 07:23:23 UTC
Thanks for the info! I will wait for that before checking both again. :)
Comment 12 Martin Kozeny 2013-04-29 07:45:29 UTC
There should be implementation for ant projects but for sure I am going to check it. But yes, better is to wait when both ant and maven implementations will be done.
Comment 13 Martin Kozeny 2013-04-29 07:56:53 UTC
FYI: I've tried build 201304282301 and it's there for ant NBM projects.
Comment 14 Quality Engineering 2013-05-09 02:37:13 UTC
Integrated into 'main-golden', will be available in build *201305082300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/53b7b150f138
User: Milos Kleint <mkleint@netbeans.org>
Log: #200833 package modification implementation for maven nbm projects, simplified api, base export action enablement/title on AccessibilityQuery result.
Comment 15 mienamoo 2013-05-24 05:36:22 UTC
Verified with build 201305212300 for both Ant and Maven projects. Thanks Martin and Milos!
Comment 16 markiewb 2013-07-07 18:45:53 UTC
(In reply to comment #15)
> Verified with build 201305212300 for both Ant and Maven projects. Thanks Martin
> and Milos!

@Martin/Milos: So this issue can be resolved as fixed? An entry in the Noteworthy page would also be useful.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo