Bug 200029 - [70cat] IllegalArgumentException: Original Node from map {position=101, iconResource=org/netbeans/modules/db/resources/database.gif, name=Databases, original=null, displayName=Databases, instanceCreate=org.op
[70cat] IllegalArgumentException: Original Node from map {position=101, iconR...
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
7.0
All All
: P2 (vote)
: 7.0.1
Assigned To: Jiri Rechtacek
issues@db
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-11 08:11 UTC by mike45
Modified: 2012-02-16 10:07 UTC (History)
16 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.23 KB, text/plain)
2011-07-11 08:11 UTC, mike45
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mike45 2011-07-11 08:11:01 UTC
This issue was reported manually by mmirilovic.
It already has 61 duplicates 


Build: NetBeans IDE 7.0 Beta (Build 201011152355)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows 7

User Comments:
GUEST: When I'm in the Services view, Selecting Databases...

jaihind: I just started the IDE, and a red icon was showing at the bottom right corer of the status bar. Clickiing on the icon popped up this dialog box. Having said that, my understanding of the problem is that it is related to the Databases node on the Services tab. Double Clicking or right-clicking on the nodes doesn't not yield any response. So, I am not able to open or crete any databased using this UI tool.

terje7601: There seems to be an issue with the Databases node. I had just started a registered GlassFish Server in NetBeans.

hmichel: Expanding Databases node at Services view.

terje7601: Cannot expand the database node without getting this error now...

GUEST: I run NetBeans IDE 7.0 over jdk-7-ea-bin-b141-windows-x64-05_may_2011 but i can't expand Databases note in Services

GUEST: When i press right clik on database node in services window the problem oncured

GUEST: Open databases service...

GUEST: I can't open DataBases Node, sorry but this bug take a very long time to be fixed.......!!!?

GUEST: i wont to connect to a database via netbeans. the node databases didn't open

GUEST: start netbeans

GUEST: trying to register MYSQL Server

GUEST: Tried to expand the database node in Services

jaihind: Right clicking on the Databases node on the Services tab caused this problem to occur.

GUEST: The database node in the services window does not work .

GUEST: Try to open the database node in the services tab.
Unable to connect to a database.

terje7601: Cannot expand the Databases node after a fresh startup of NetBeans

lhochet: still present in the latest daily (20110090000)

GUEST: Services. Right Click on Databases menu item.

GUEST: right click on 'Databases' in the 'Services' view *bang*

GUEST: Expand Database node in service window

GUEST: Tengo windows 7 home a x64 y no podido que el servcio de basede datos me muestre los motores que tiene instalado, no tiene opciones de seleccion tendo isntalado JDK 7 x64, probe con 32bit y tampoco que debo hacer, una vez puede pero cuando fui a crear ejb con remote  no lo permitio.

Garcias

GUEST: Can't open Services/Database
 * Setup fresh netbean 7.0
 * Enviroment windows 7(64bit), jre7 & jdk7(32bit)

Pootzjava: O Erro ocorre quando clico na op
Comment 1 mike45 2011-07-11 08:11:06 UTC
Created attachment 109356 [details]
stacktrace
Comment 2 Jiri Rechtacek 2011-07-12 10:10:03 UTC
No more reports after NB7.0 (none from 701 or Dev builds), probably the problem disappeared after NB7.0.
Comment 3 faiz_ali 2011-07-30 09:17:44 UTC
cannot right click or left click in Services-->Databases !!!!
Comment 4 Tomas Danek 2011-08-01 09:34:05 UTC
no luck reproducing this on 7.0.1 (2011-07-28) with jdk7 b147.
Comment 5 Jiri Rechtacek 2011-09-15 11:19:44 UTC
ramayu, you are running NB6.9.1 on JDK1.7 which causes this problem. To run IDE on JDK1.7 you have to upgrade your NetBeans to 7.0.1, or if you need keep NB6.9.1. to have to run it on JDK1.6. Hope this helps

It's still true there are no more reports after NB7.0 (none from 701 or Dev builds), the problem was fixed in NB7.0.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo