Bug 199988 - Wrong URL to NetBeans Distribution UC in ML builds
Wrong URL to NetBeans Distribution UC in ML builds
Status: VERIFIED FIXED
Product: nblocalization
Classification: Unclassified
Component: Code
7.0.1
All All
: P1 (vote)
: 7.0.1
Assigned To: issues@nblocalization
issues@nblocalization
:
Depends on:
Blocks: 198085
  Show dependency treegraph
 
Reported: 2011-07-08 13:41 UTC by Jiri Rechtacek
Modified: 2011-07-18 08:44 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2011-07-08 13:41:39 UTC
Quoted from issue 198085:
> - Install NetBeans 7.0.1rc1 with ru_RU.UTF-8 locale by
> - Start netbeans by /opt/netbeans-7.0.1rc1/bin/netbeans
> - Check Plugins window
> ==>
> main update center is
> http://updates.netbeans.org/netbeans/updates/7.0/uc/final/distribution/catalog_ru.xml.gz
> Available C/C++ version is 1.13.1.1
> 
> - Install NetBeans 7.0.1rc1 with en_EN.UTF-8 locale by 
> LANG=en_EN.UTF-8
> - Start netbeans by LANG=en_EN.UTF-8 /opt/netbeans-7.0.1rc1/bin/netbeans
> - Check Plugins window
> ==> main update center is
> http://updates.netbeans.org/netbeans/updates/7.0.1/uc/final/certified/catalog.xml.gz
> Available C/C++ version is 1.14.2.1
Comment 1 Tomas Danek 2011-07-12 09:13:29 UTC
FYI: http://updates.netbeans.org/netbeans/updates/7.0.1/uc/final/distribution/catalog_ru.xml.gz exists, so it seems to me like IDE needs just to link this correct one.
Comment 2 Petr Jiricka 2011-07-12 15:01:16 UTC
Looking at the localized files, I think the problem is in the localization if the update center URL:
http://hg.netbeans.org/releases/l10n/file/a3458fc01808/src/ru/nb/updatecenters/updatecenters/org/netbeans/modules/updatecenters/resources/Bundle_ru.properties

This file contains the following:
URL_Distribution=http://updates.netbeans.org/netbeans/updates/7.0/uc/final/distribution/catalog_ru.xml.gz?{$netbeans.hash.code}

I.e. it points to NB 7.0 UC, not 7.0.1. But this line is marked as #NOI18N, so it should not be in the translated file at all.
Comment 3 Masaki Katakai 2011-07-12 21:34:10 UTC
Thank you for filing issue!

I didn't notice the recent update around the URL. I have picked up 7/10 files and confirmed it. I updated these URL to point to 7.0.1.

http://hg.netbeans.org/releases/l10n/rev/5ebb02ca8f45
Comment 4 Jiri Rechtacek 2011-07-18 08:44:22 UTC
Verified in:

  Product Version         = NetBeans IDE 7.0.1 (Build 201107160900) (#4e967ff248c7)
  Operating System        = Linux version 2.6.38-10-generic running on amd64
  Java; VM; Vendor        = 1.6.0_23; Java HotSpot(TM) 64-Bit Server VM 19.0-b09; Sun Microsystems Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_23-b05
  Java Home               = /usr/local/share/java/jdk1.6.0_23/jre
  System Locale; Encoding = ru (nb); UTF-8


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo