Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 199939 - Show '@Ignore'd tests in 'Test Results'
Show '@Ignore'd tests in 'Test Results'
Status: RESOLVED DUPLICATE of bug 186276
Product: java
Classification: Unclassified
Component: JUnit
7.0
All All
: P3 (vote)
: TBD
Assigned To: Theofanis Oikonomou
junit-issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-07 08:08 UTC by tomzi
Modified: 2012-03-27 11:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomzi 2011-07-07 08:08:40 UTC
Currently, when I run Tests using 'right click'/(Test File|Debug File|Run Focused Test|Debug Focused Test) and I have @Ignored tests in my Junit Test the result view is quite confusing.

Eg. If I have one @Test method in my Junit test which is marked @Ignore'd then Netbeans would show the whole test as 'passed', but when I click on the green button to show which tests passed it wouldn't show me any tests and also the bar at the top is 'red' with '0.0' percent. Which is quite confusing. I can only find out why, if I go back to the test to see that it has been @Ignore'd

In my opinion it would be better
.) that the bar would be green since all tests 'passed', with 100%
.) and also show that there have been found '@Ignore'd tests. Maybe add a new Icon, which shows also the Ignored tests

Regards
Tom

Product Version = NetBeans IDE Dev (Build 201106041000)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.6.0_25
Runtime = Java HotSpot(TM) 64-Bit Server VM 20.0-b11
Comment 1 Martin Janicek 2011-12-05 15:27:47 UTC
+1 

..I was just creating new enhancement when I've found that similar issue is already here. It seems that we have no @Ignore annotation support at the moment in Netbeans (even in 7.1 if I didn't missed something), so it's still more enhancement than defect.

Just FYI for example in Eclipse it's done in a similar way as tomzi described. That means - ignored tests are counted as 'passed', but they are marked by some special flag to show user that he still has some ignored tests to implement/rewrite/whatever. And it would be a really good idea to do this inside a new icon for ignored tests.
Comment 2 Theofanis Oikonomou 2012-03-27 11:50:09 UTC

*** This bug has been marked as a duplicate of bug 186276 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo