Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 199865 - NetBeans fails to re-display Applications in Services window
NetBeans fails to re-display Applications in Services window
Status: RESOLVED WONTFIX
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.0.1
All All
: P4 (vote)
: TBD
Assigned To: TomasKraus
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-03 20:41 UTC by muellermi
Modified: 2013-01-04 12:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-07-03 20:41:49 UTC
Product Version = NetBeans IDE 7.0.1 RC1 (Build 201106222100)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0
Runtime = Java HotSpot(TM) 64-Bit Server VM 21.0-b17

From TS_70_GlassFish:
Application Node

    Run project (F6)
    Expand "Servers|GlassFish Default|Applications" node in Services View
    Check deployed application is present
    Right-click WebApplication1 node and choose Disable
    Try to refresh page in browser and check it is not available. Check also badge on the node
    Right-click WebApplication1 node and choose Enable
    Refresh page in browser and check it is available. Check also badge on the node disappears
    Right-click WebApplication1 node and choose Open in Browser
    Check browser is opened
    Right-click WebApplication1 node and choose Undeploy
    Check WebApplication1 node disappears and application is not available in browser after refresh
    Run project (F6) again and expand "Servers|GlassFish Remote|Applications" node
    Check application is visible tha same way as in "GlassFish Default" instance and repeat all above steps for this remote instance <<<<<<<<<<
Apllication nodes stays empty.
After stopping the server and re-starting the app, it will display the expected values.
Comment 1 Vince Kraemer 2011-07-13 18:23:05 UTC
(In reply to comment #0)
> Product Version = NetBeans IDE 7.0.1 RC1 (Build 201106222100)
> Operating System = Windows 7 version 6.1 running on amd64
> Java; VM; Vendor = 1.7.0
> Runtime = Java HotSpot(TM) 64-Bit Server VM 21.0-b17
> 
> From TS_70_GlassFish:

is there a link to this test suite?

> Application Node
> 
>     Run project (F6)
>     Expand "Servers|GlassFish Default|Applications" node in Services View
>     Check deployed application is present
>     Right-click WebApplication1 node and choose Disable
>     Try to refresh page in browser and check it is not available. Check also
> badge on the node
>     Right-click WebApplication1 node and choose Enable
>     Refresh page in browser and check it is available. Check also badge on the
> node disappears
>     Right-click WebApplication1 node and choose Open in Browser
>     Check browser is opened
>     Right-click WebApplication1 node and choose Undeploy
>     Check WebApplication1 node disappears and application is not available in
> browser after refresh

Did you forget to mention a step here?

>     Run project (F6) again and expand "Servers|GlassFish Remote|Applications"
> node
>     Check application is visible tha same way as in "GlassFish Default"
> instance and repeat all above steps for this remote instance <<<<<<<<<<
> Apllication nodes stays empty.
> After stopping the server and re-starting the app, it will display the expected
> values.
Comment 2 Petr Jiricka 2011-07-13 19:33:56 UTC
Here is the test spec: http://wiki.netbeans.org/TS_70_GlassFish
Comment 3 Vince Kraemer 2011-10-26 18:30:46 UTC
There is no link between deploying to server A and updating the subnodes of a server B -- even if the two nodes refer to 'the same server'

Using the refresh item on server B updates the subnodes

Lowering to p4
Comment 4 TomasKraus 2013-01-04 12:11:53 UTC
I do agree with Vince. Now there is nothing that joins 2 server nodes together.
Nodes content is refreshed with events related to the nodes itself. No cross-nodes update is implemented.

There are no plans to implement such a thing like 'refresh all nodes' or 'refresh all nodes pointing to the same host:port'.

This is not a bug in existing functionality but an RFE request. If someone would like to get this implemented, please file/reopen this as an RFE.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo