Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 199697 - Huge memory consumption when parsing large C/C++ project
Huge memory consumption when parsing large C/C++ project
Status: RESOLVED DUPLICATE of bug 197297
Product: cnd
Classification: Unclassified
Component: Code Model
7.0
PC Linux
: P3 (vote)
: 7.2
Assigned To: issues@cnd
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-25 19:35 UTC by _ rsmogura
Modified: 2012-04-03 18:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ rsmogura 2011-06-25 19:35:28 UTC
When I import/parse large C/C++ the whole heap memory is consumed. When I right click on Project/Code assistance and when I unmark C/C++ Code Assistance, memory consumption is quite well.

The good test environment will be Linux sources, download it and build with common "desktop" options - more *.o files more parsing - turn debugging sumbols under Kernel hacking tree. Then import it to Netbeans.

I had reserved 2GB heap, and parsing was out of memory at 30% (only garbage collector was warking), this means that I should have about 8GB stack!
Comment 1 Vladimir Voskresensky 2011-06-25 19:39:21 UTC
thanks for the report. 
And you are right. Btw, if you use 64bit java you can reduce memory consumption about twice by using 32bit version.
I think we discuss the same issue in the report http://netbeans.org/bugzilla/show_bug.cgi?id=197297
Comment 2 Vladimir Voskresensky 2011-06-25 19:41:35 UTC
as workaround I can propose you to create project from binary files (one project per binary) => you will have multi projects, but they should fit into memory better if opened not all at once
Comment 3 Vladimir Voskresensky 2012-04-03 18:41:55 UTC

*** This bug has been marked as a duplicate of bug 197297 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo