Bug 199622 - JavaFX 2.0 composer
JavaFX 2.0 composer
Status: RESOLVED WONTFIX
Product: javafx
Classification: Unclassified
Component: Editor
7.0
PC Windows 7 x64
: P4 (vote)
: 7.0.1
Assigned To: Anton Chechel
issues@javafx
: PLAN, UI, USABILITY
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 14:10 UTC by unai
Modified: 2011-06-23 12:31 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description unai 2011-06-22 14:10:16 UTC
It would be extremely convenient to have the JavaFX composer back (for javaFX 2.0) in order to be able to visually design javafx GUIs, like Matisse allows you to do with Swing.

I've been digging through the Internet, but I only found out that NB 7.0 doesn't support it: crossing fingers and hoping that the upcoming version will...
Comment 1 Anton Chechel 2011-06-23 12:31:42 UTC
Unfortunately in Oracle we are not supposed to talk about any plans.
Here is official response:

"JavaFX 2.0 is a major update to the JavaFX platform. Starting with this version, developers can create JavaFX applications completely in the Java programming language using standard Java development tools, and the JavaFX Script programming language will not be supported in JavaFX 2.0 and future releases. 

NetBeans composer, a visual GUI designer for JavaFX, was designed for the JavaFX Script language. We are actively working on providing a similar developer experience for JavaFX 2.0. More details and roadmap on this topic will be available soon. For specific questions please contact the JavaFX product team at javafx-support@sun.com."


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo