Bug 199387 - To export all - exports not all
To export all - exports not all
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Editor
7.0.1
PC Linux
: P3 (vote)
: 7.0.1
Assigned To: Alexander Simon
issues@cnd
701patch1-verified
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-13 19:39 UTC by yuriy_lalym
Modified: 2011-09-26 13:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
~/.netbeans (7.15 MB, application/octet-stream)
2011-06-16 22:39 UTC, yuriy_lalym
Details
At me it turns out always. (5.03 MB, application/octet-stream)
2011-06-18 10:54 UTC, yuriy_lalym
Details
messages.log (134.84 KB, application/octet-stream)
2011-06-21 20:08 UTC, yuriy_lalym
Details
netbeans.conf (1.56 KB, application/octet-stream)
2011-06-21 20:10 UTC, yuriy_lalym
Details
netbeans.import (5.28 KB, application/octet-stream)
2011-06-21 20:11 UTC, yuriy_lalym
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yuriy_lalym 2011-06-13 19:39:25 UTC
I created a profile "Fonts and Colors" Obsidian for languages C, C++, С/С++ Headers.

Tools->Options->Export
Select file - all.zip
Select All
Ok

In  all.zip/config/Editors/text no x-c, x-c++ directories.
Comment 1 Yulia Novozhilova 2011-06-16 17:30:49 UTC
Could you please zip and attach your .netbeans/dev/config folder after creating the profile?
Comment 2 yuriy_lalym 2011-06-16 22:39:22 UTC
Created attachment 108938 [details]
~/.netbeans

Product Version: NetBeans IDE Dev (Build 201106161124)
Java: 1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 21.0-b15
System: Linux version 2.6.39.1-32-desktop running on amd64; UTF-8; en_US (nb)
Userdir: /home/yura/.netbeans/dev
Comment 3 Yulia Novozhilova 2011-06-17 16:17:27 UTC
Well, I can't reproduce the issue on my Windows machine. Everything is exported. Will try on Linux later. Is it reproducible all the time for you?
Comment 4 yuriy_lalym 2011-06-18 10:54:48 UTC
Created attachment 108973 [details]
At me it turns out always.
Comment 5 Yulia Novozhilova 2011-06-21 12:40:27 UTC
I still can't reproduce. Could you please run NetBeans with
-J-Dorg.netbeans.modules.options.export.OptionsExportModel.level=FINEST (you can add it to etc/netbeans.conf at netbeans_defaul_options line), then reproduce the problem and attach the log file here. It would be also helpful if you attach etc/netbeans.import file here.
Comment 6 yuriy_lalym 2011-06-21 20:08:49 UTC
Created attachment 109031 [details]
messages.log
Comment 7 yuriy_lalym 2011-06-21 20:10:16 UTC
Created attachment 109032 [details]
netbeans.conf
Comment 8 yuriy_lalym 2011-06-21 20:11:48 UTC
Created attachment 109033 [details]
netbeans.import
Comment 9 Yulia Novozhilova 2011-06-23 16:14:01 UTC
From your netbeans.import file, line 40:

>exclude config/Editors/text/x-c.*

This line causes such a behavior.  Removing it fix the problem.

It looks like this fix http://hg.netbeans.org/core-main/rev/581fd2f98fe7 is responsible for this. Reassigning to CND. Alexander, please comment.
Comment 10 Alexander Simon 2011-06-23 16:53:32 UTC
(In reply to comment #9)
> From your netbeans.import file, line 40:
> 
> >exclude config/Editors/text/x-c.*
> 
> This line causes such a behavior.  Removing it fix the problem.
> 
> It looks like this fix http://hg.netbeans.org/core-main/rev/581fd2f98fe7 is
> responsible for this. Reassigning to CND. Alexander, please comment.
It a bug. Should be excluded only:
/config/Editors/text/x-c++/Preferences/org-netbeans-modules-editor-settings-CustomPreferences.xml
/config/Editors/text/x-c/Preferences/org-netbeans-modules-editor-settings-CustomPreferences.xml
Comment 11 Alexander Simon 2011-06-23 17:10:42 UTC
fixed, change set:
http://hg.netbeans.org/releases/rev/d72f0c37b15b

It is regression in NB7.0.1.
QA: evaluate bug as showstopper.
Comment 12 Quality Engineering 2011-07-26 13:57:43 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/1fd47a83c88e
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #199387 To export all - exports not all
Comment 13 Alexander Simon 2011-08-15 10:31:31 UTC
Fix trancplanted to release701_fixes on elif:
1fd47a83c88e transplanted to 17a237561ec5
Comment 14 Alexander Pepin 2011-08-19 13:41:00 UTC
verified in OSS IDE build #28.
Comment 15 Alexander Simon 2011-08-24 11:29:33 UTC
integrated in release701_fixes:
17a237561ec5 transplanted to d972fc34e43b
Comment 16 Quality Engineering 2011-08-25 04:27:08 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/d972fc34e43b
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #199387 To export all - exports not all
(transplanted from 17a237561ec51a3e55793de31ee633f2da2a0515)
Comment 17 Alexander Pepin 2011-08-29 15:46:42 UTC
verified in 7.0.1 patch1
Comment 18 Quality Engineering 2011-09-26 13:28:26 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/17a237561ec5
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #199387 To export all - exports not all


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo