Bug 199214 - isSecurePort doesn't use proxy
isSecurePort doesn't use proxy
Status: NEW
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.1
PC Other
: P4 (vote)
: 7.4
Assigned To: Vince Kraemer
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 19:43 UTC by Vince Kraemer
Modified: 2012-11-27 15:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2011-06-06 19:43:53 UTC
this makes some use cases difficult.
Comment 1 Vince Kraemer 2011-06-09 16:30:40 UTC
this method is called by getHttpListenerProtocol(String,int).

That method is necessary for v3 Prelude, v3, 3.0 and 3.0.x servers.

It does not need to be called for 3.1 servers, since those servers provide redirects in situations where the user and/or a program attempt to use http to access a secured listener.
Comment 2 Vince Kraemer 2011-10-26 19:16:03 UTC
lowering to p4...

The listed servers are obsoleted by 3.1.1
Comment 3 TomasKraus 2012-11-27 15:43:12 UTC
Targeting to next release. We have to get plugin working correctly even with old 3.0 versions.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo